No Awstats updating since server move

fuzioneer

Well-Known Member
Dec 12, 2003
100
0
166
We switched servers a month or so ago and all seemed to go ok, but now all the accounts aren't automatically updating awstats :(

all the historic data is there from the last few years but nothing for any day last month

I could initially click on the manual update link within awstats but now when i try this i get an error stating
"Error: Log is currently being processed in the background. Cannot update. "

hellllpppp ;)

running:
WHM 11.28.76
CENTOS 5.5 x86_64 standard
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Could you try running one of the user's stats manually to see if you receive any errors?

Code:
/scripts/runweblogs username
Replacing username with the cPanel username. Please paste the output here for us to see the results. Also, please let us know if that set user's stats do then update.

It's possible cpanellogd is not updating or hanging on a log for some reason, you could try restarting cPanel itself to see if that helps:

Code:
/etc/init.d/cpanel restart
 

fuzioneer

Well-Known Member
Dec 12, 2003
100
0
166
i tweaked the load settings for stats and successfully got the stats to run :)

hopefully that was the root cause for this server

Now another server has the same issue but not the same cause :(

Code:
Log checker loaded ok..
==> cPanel Log Daemon version 24.0
Processing logs during blackout period...
==> Loaded RRDs: version 1.3006
==> WARNING: The configured processor count does not match the
==> actual processor count (4)! Running log analysis programs
==> on this system may cause excessive load! You should set "extracpus"
==> to "0" in /var/cpanel/cpanel.config if this is not ok.
Processing admin...
Run Logs domain: domain.com BW Limit: 104857600000 Domains: []
info [safeapacherestart] Restart elapsed seconds: 1
[2011-02-03 08:57:43 +0000] Process bandwidth for admin
[2011-02-03 08:57:44 +0000] Processing exim stats for admin....
[2011-02-03 08:57:44 +0000] ...Done
info [safeapacherestart] Restart elapsed seconds: 1
[2011-02-03 08:58:03 +0000] WEBLANG english
[2011-02-03 08:58:03 +0000] Archive Status: 0
[2011-02-03 08:58:03 +0000] About to fork for admin[DOMAIN: domain.com]
Complete
i get this on all accounts on this server ?
 

LinuxTechie

Well-Known Member
Jan 22, 2011
502
10
68
cPanel Access Level
Root Administrator
Hello,

I could see a warning in the log.

==> WARNING: The configured processor count does not match the
==> actual processor count (4)! Running log analysis programs
==> on this system may cause excessive load! You should set "extracpus"
==> to "0" in /var/cpanel/cpanel.config if this is not ok.

Can you please check this out adn confirm everything is okay!
 

fuzioneer

Well-Known Member
Dec 12, 2003
100
0
166
this is just because we know our server spikes at night so by configuring that setting it allows the stats to process instead of being stalled due to high load.

this isn't the cause of the issue though, it doesn't appear to be processing any logs as normally there are more text lines with number of lines processed etc