no bind configuration present! [Please Help]

Russell. H

Registered
Jul 2, 2008
2
0
51
Hi there,

I was updating my WHM 11 server last night and it appears that somthings gone wrong. It wasn't a full version upgrade like 10-11 it was just a normal update.

I have google'd untill I could google no more! I can't find a solution to fix this. So if any of you could help, I would be most greatful!

I've tried reinstalling cPanel it's self, this how ever did not fix the issue.

So I tried the suggested command: /home/installd/checkresolvconf, the output from the console just says yes.

Then I tried: /scripts/rebuildnamedconf (/scripts/fixndc = same script?), the results:

[email protected] [/var/cache]# /scripts/rebuildnamedconf
[cPScript::NameServer::Utils::BIND]: Attempting to locate /etc/named.conf
[cPScript::NameServer::Utils::BIND]: no bind configuration present
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
safeopen: Invalid arguments at /scripts/cPScript/NameServer/Conf/BIND.pm line 268
named/
named/named.zero
named/localdomain.zone
named/named.broadcast
named/named.ip6.local
named/named.local
named/localhost.zone
named/
named/named.zero
named/localdomain.zone
named/named.broadcast
named/named.ip6.local
named/named.local
named/localhost.zone
[cPScript::NameServer::Utils::BIND]: Attempting to locate /etc/named.conf
[cPScript::NameServer::Utils::BIND]: no bind configuration present
[cPScript::DNSLib]: Unable to locate Bind configuration file.
I was wondering if there was a command to reinstall the bind or even the whole named (dns)?

Any help would be amazing!

Thanks,
Russell
 
Last edited:

Russell. H

Registered
Jul 2, 2008
2
0
51
Ok the fix:

# /scripts/rebuildnameconf
# /scripts/fixnamedviews

run those two commands, and thank Jared Ryan in the Technical Dep. :)