The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no cgi-bin alias in httpd.conf an no bw logs

Discussion in 'General Discussion' started by apogee, Jun 23, 2005.

  1. apogee

    apogee Well-Known Member

    Joined:
    Nov 8, 2004
    Messages:
    107
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Europe
    cPanel Access Level:
    DataCenter Provider
    Hello,

    all accounts setuped after the 2005 06 14 have NO cgi-bin in my httpd.con, so cgi would not work for new customers. Why happens this? I always give the accounts cgi-bin in the setup section. How cna i fix this?

    The other error is, that all acconts after 2005 06 14 have no logs, if I check Account Information/View Bandwidth Usage there are no infos about alle domains setupt after the 2005 06 14

    have anybody the same error?

    thanks
     
  2. apogee

    apogee Well-Known Member

    Joined:
    Nov 8, 2004
    Messages:
    107
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Europe
    cPanel Access Level:
    DataCenter Provider
    Hello,

    I've found a new problem with the new accounts on the box, thy server don't count web traffic. I have no idea whats wrong

    BTW: I'm using edge
     
  3. troxalias

    troxalias Well-Known Member

    Joined:
    Nov 21, 2001
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Athens - Greece
    Same problem with cgi-bin alias not being created in httpd.conf . Very annoying to add this manually for every single new hosting.
     
  4. DIYHosting

    DIYHosting Well-Known Member

    Joined:
    Nov 27, 2003
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Saskatoon, SK, Canada
    This is happening on both of my servers as well!
     
  5. apogee

    apogee Well-Known Member

    Joined:
    Nov 8, 2004
    Messages:
    107
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Europe
    cPanel Access Level:
    DataCenter Provider
    thanks for answering, its good to know that I'm not the only one with this problem
     
  6. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    cgi-bin alias missing on my recent accounts as well on 3 servers so far!
    Would be great to get this fixed ASAP.
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Have you informed cPanel about this, either through a bugzilla entry or a support ticket? Otherwise, they could well be unaware. If you log it in bugzilla, post the entry link here.
     
  8. df66

    df66 Member

    Joined:
    May 29, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I'm seeing this on Fedora core 2, Redhat 9 and Redhat Enterprise 3 where the ScriptAlias line is missing from httpd.conf. Centos 3.4 (x86_64) isn't affected. All are running WHM 10.1.0 current release.

    A temporary fix is to use the "edit packages" feature, select the package used by the account recently added and click the edit button without changing anything. This goes through all the accounts and corrects the problem in the httpd.conf file.

    It's now logged with bugzilla - http://bugzilla.cpanel.net/show_bug.cgi?id=2721
     
  9. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    go into whm under setup and change script allias from y to n
     
  10. DomineauX

    DomineauX Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    414
    Likes Received:
    4
    Trophy Points:
    18
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Is it maybe because of this:


    !hascgi!=1!
    Options -ExecCGI -Includes
    !hascgi!
    !scriptalias=1!
    ScriptAlias /cgi-bin/ %docroot%/cgi-bin/
    !scriptalias!


    Notice how the !hascgi! and !scriptalias! directives are repeated? First time with a =1 then again with nothing?
    This is inside /usr/local/cpanel/etc/httptemplates/apache1/default
     
Loading...

Share This Page