The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No DMA Mode!

Discussion in 'General Discussion' started by evisions, Feb 23, 2005.

  1. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    I recently discoverd that under server status my drives are displaying No DMA! (Click to Enable).... I did some reading through other similar posts and found that this is a potential indicator or HDD issues, but I don't think this is the case here.... I have two drives in the machine, and both are displaying the No DMA! flag, it seems unlikely that both drives could be going bad, though they are identical drives.... Both are SMART capable Seagate Baracuda 7200 RPM SATA Drives on a Super Micro MB. I'm sure that they were running in DMA mode when the machine was first brought online, though I'm not sure when they stopped running in DMA.... I'm running a Stock Redhat Kernal 2.4.20-31.9 which should have DMA support built in.... hdparm reports the following on the drives:

    hdparm /dev/hda

    /dev/hda:
    multcount = 16 (on)
    IO_support = 1 (32-bit)
    unmaskirq = 1 (on)
    using_dma = 0 (off)
    keepsettings = 0 (off)
    readonly = 0 (off)
    readahead = 8 (on)
    geometry = 9729/255/63, sectors = 156301488, start = 0


    hdparm /dev/hdc

    /dev/hdc:
    multcount = 16 (on)
    IO_support = 1 (32-bit)
    unmaskirq = 1 (on)
    using_dma = 0 (off)
    keepsettings = 0 (off)
    readonly = 0 (off)
    readahead = 8 (on)
    geometry = 9729/255/63, sectors = 156301488, start = 0


    When I attempt to activate DMA in cpanel I receive the following:

    EIDE Hard Drive Optimizations Enabled
    /dev/hda:
    setting 32-bit IO_support flag to 1
    IO_support = 1 (32-bit)
    /dev/hdc:
    setting 32-bit IO_support flag to 1
    IO_support = 1 (32-bit)

    But it doesn't go into DMA mode.... When I use hdparm -d1 /dev/hda (to enable DMA) I get the following:
    /dev/hda:
    setting using_dma to 1 (on)
    HDIO_SET_DMA failed: Operation not permitted
    using_dma = 0 (off)

    It is the same for the other drive....

    Naturally I'm having performance issues because of the lack of DMA support.... What are my options at this point? What else can I do to determine the source of the failing DMA support.... I don't find anything in the logs related to an attempt to use DMA at boot time failing....
     
  2. networxhosting

    networxhosting Well-Known Member
    PartnerNOC

    Joined:
    Apr 22, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hamilton, Ontario, CANADA
    did you ever get this resolved?

    Im having the exact same problems with a stock RHEL kernel with SATA drives, DMA will not enable

    Any ideas? anyone?
     
  3. evisions

    evisions Well-Known Member

    Joined:
    Jan 25, 2004
    Messages:
    68
    Likes Received:
    0
    Trophy Points:
    6
    Yes, I actually discovered that my system slipped into an old kernel. I corrected the issue by switching to the correct kernel.
     
  4. .marius

    .marius Registered

    Joined:
    Jun 29, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Recompile the kernel enabling DMA...
     
Loading...

Share This Page