The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no immediate delivery: more than 10 messages received in one connection

Discussion in 'E-mail Discussions' started by davidjC, May 20, 2008.

  1. davidjC

    davidjC Registered

    Joined:
    May 20, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    (I have root access)

    I am seeing this in the log file:

    no immediate delivery: more than 10 messages received in one connection

    We send out an email newsletter and since this started in the last month or so it takes eons to send out emails.

    How can I tweak this to allow unlimited (or at least 100 per batch) connections?

    What setting do I need to add/tweak/remove?

    Many thanks!
     
  2. davidjC

    davidjC Registered

    Joined:
    May 20, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    (bump thread)

    Can anyone help here please?

    Thank you.
     
  3. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Do you have root access to the server?
     
  4. davidjC

    davidjC Registered

    Joined:
    May 20, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Yes I do have root access.
     
  5. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I apologize for not seeing that in your original post. I can't think of any settings offhand that would cause this. I recommend having one of our technical analysts take a look at this for you:

    http://tickets.cpanel.net/submit
     
  6. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Have a look at the smtp_accept_queue_per_connection for exim. By default it is not listed in the exim.conf file and defaults to 10. You might try adding something like:

    smtp_accept_queue_per_connection 30

    to your exim.conf.

    Though a better solution might be to actually limit the number of messages to 10 per SMTP connection.
     
  7. wemail

    wemail Well-Known Member

    Joined:
    Nov 28, 2006
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    GB
    cPanel Access Level:
    Root Administrator
    Does this limit apply to GNU Mailman users sending to lists such that numerous emails are transmitted at one time?
     
  8. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,384
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    I would assume so since the setting is part of exim and not part of mailman.
     
  9. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16
    Hello!

    Same issue here - never had that problem before!

    It's pretty cool to be able to force/split mass mailings with the exim mail que

    - but I don't want to have it.

    If I change exim.conf it will be over written on updates right ?

    cPanel should look in to this and maybe add a function in tweak to set it!
     
  10. jeroman8

    jeroman8 Well-Known Member

    Joined:
    Mar 14, 2003
    Messages:
    410
    Likes Received:
    0
    Trophy Points:
    16

    Do you know where I can put "smtp_accept_queue_per_connection" in exim.conf ?

    I tried under TRANSPORTS CONFIGURATION but Exim wont start when adding it.
     
  11. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,126
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I am noticing large Mailman delivery delays, and see a lot of this in the logs:

    no immediate delivery: more than 10 messages received in one connection

    I've seen the suggestion to increase this to 30, by adding this to exim.conf

    smtp_accept_queue_per_connection 30

    However, I need some help as to which section inside the WHM Exim configuration editor, would I place this new line?

    Thanks!

    - Scott
     
Loading...

Share This Page