Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED No LetsEncrypt in AutoSSL providers

Discussion in 'Security' started by allpar, Dec 19, 2017.

Tags:
  1. allpar

    allpar Well-Known Member

    Joined:
    Sep 16, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    156
    In WHM, Manage AutoSSL on one server shows three providers: Disabled, LetsEncrypt, and CPanel.

    In WHM of a different server, it does not show LetsEncrypt.

    I tried uninstalling the LetsEncrypt plugin and reinstalling it. There were no errors but it also apparently didn't do anything. I also tried restarting WHM, and that also did not update anything.

    Thoughts? Troubleshooting tips? Here's the installation...

    Code:
    Setting up Install Process
    Loading mirror speeds from cached hostfile
     * EA4: 208.100.0.204
     * cpanel-addons-production-feed: 208.100.0.204
    19 packages excluded due to repository priority protections
    Resolving Dependencies
    --> Running transaction check
    ---> Package cpanel-letsencrypt.noarch 0:2.16-8.1 will be installed
    --> Finished Dependency Resolution
    
    Total download size: 34 k
    Installed size: 97 k
    Downloading Packages:
    Running rpm_check_debug
    Running Transaction Test
    Transaction Test Succeeded
    Running Transaction
      Installing : cpanel-letsencrypt-2.16-8.1.noarch                           1/1
      Verifying  : cpanel-letsencrypt-2.16-8.1.noarch                           1/1
    Complete!
     
    #1 allpar, Dec 19, 2017
    Last edited by a moderator: Dec 19, 2017
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    I'm unable to reproduce this issue on a test system. Can you verify which version of cPanel is installed on this system? Are you sure you are accessing Web Host Manager over the same IP address that you used when installing the plugin via the command line?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. allpar

    allpar Well-Known Member

    Joined:
    Sep 16, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    156
    Thanks. 68.0.20 and I am pretty sure it's the same IP. Let me install .21 and see if that helps.
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Feel free to open a support ticket using the link in my signature if the cPanel update doesn't help and we will take a closer look at the affected system.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. allpar

    allpar Well-Known Member

    Joined:
    Sep 16, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    156
    No... that did not help. Do you want me to do a ticket?
     
  6. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Yes, please open a support ticket so we can take a closer look. You can post the ticket number here and we will update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. allpar

    allpar Well-Known Member

    Joined:
    Sep 16, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    156
    Ticket 9122889 - thanks! Sorry for cross-posting on you.
     
  8. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    To update, the issue was solved by running the installation script again:

    Code:
    /scripts/install_lets_encrypt_autossl_provider
    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. allpar

    allpar Well-Known Member

    Joined:
    Sep 16, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    156
    I will attest to the fact that worked — though again, you can see at the top of the page that I'd already rerun the script to no avail! So ... I’m going to attribute it partly to the script and partly to magic. :)

    Kudos to the CPanel support team — for caring, as much as for fixing.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice