Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

no listening sockets available, shutting down, Unable to open logs

Discussion in 'General Discussion' started by capoinfra, Oct 1, 2013.

  1. capoinfra

    capoinfra Well-Known Member

    Joined:
    Oct 25, 2007
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    66
    Location:
    Uruguay
    Hello,

    We are unable to get apache working.

    It show this error:

    service httpd start
    no listening sockets available, shutting down
    Unable to open logs

    We check port 80 with netstat, lsof, and there are no processes using that port.
    Firewall is stoped
    Also we recompiled with easy apache, reboot the server but the error persist.
    We ran /scripts/upcp and /scripts/upcp --force but the problem persist.

    Any idea please?

    Thank you.-
     
  2. quietFinn

    quietFinn Well-Known Member

    Joined:
    Feb 4, 2006
    Messages:
    998
    Likes Received:
    11
    Trophy Points:
    168
    Location:
    Finland
    cPanel Access Level:
    Root Administrator
    Check that you are not out of disk space.

    df -h
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. capoinfra

    capoinfra Well-Known Member

    Joined:
    Oct 25, 2007
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    66
    Location:
    Uruguay
    Hello,

    The disk space is not the problem.

    Thank you.
     
  4. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,532
    Likes Received:
    1,966
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    Please check the output of the Apache error log:

    Code:
    /usr/local/apache/logs/error_log
    Do you notice any specific output when attempting to start Apache?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. zmacintyre

    zmacintyre Registered

    Joined:
    Nov 9, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    I would guess (if you haven't already figured this out) that you are including a conf file from the /conf/extras folder that is trying to listen on the same port. Look through your httpd.conf file for any included *.conf files and then check them out to see if they have a Listen directive set on 80. This happened to me when I initially setup the httpd.conf to use 443 and then later enabled the httpd-ssl.conf file which was trying to listen on the same port.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice