Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

No Match for argument: libXpm-dev

Discussion in 'General Discussion' started by Tagor, Dec 30, 2005.

  1. Tagor

    Tagor Well-Known Member

    Joined:
    Mar 6, 2004
    Messages:
    193
    Likes Received:
    0
    Trophy Points:
    166
    I need to install libXpm but I get an error. Does someone know how to fix this?

    Thank a lot :)

     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    There's no such rpm. What exactly do you want to install? If it's the libXpm libraries, then it depends on your OS:

    RHE3/CentOS3 rpm is XFree86-devel
    RHE4/CentOS4 rpm is xorg-x11-devel
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. Tagor

    Tagor Well-Known Member

    Joined:
    Mar 6, 2004
    Messages:
    193
    Likes Received:
    0
    Trophy Points:
    166
    That's correct. I want to install libXpm. I am using CentOS 4 (64 bit)
     
  4. Tagor

    Tagor Well-Known Member

    Joined:
    Mar 6, 2004
    Messages:
    193
    Likes Received:
    0
    Trophy Points:
    166
    I am trying to compile apache but I still get this error:
    configure: error: libXpm.(a|so) not found.

    This is what the yum install said:
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Do this:

    rpm -e --justdb fontconfig

    Then run your yum line again.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. Tagor

    Tagor Well-Known Member

    Joined:
    Mar 6, 2004
    Messages:
    193
    Likes Received:
    0
    Trophy Points:
    166
    After running the rpm line I get this:

     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Try this instead:

    rpm -e --justdb --nodeps fontconfig fontconfig-devel
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. moFBush

    moFBush Well-Known Member

    Joined:
    Dec 31, 2005
    Messages:
    51
    Likes Received:
    0
    Trophy Points:
    156
    HOWTO run "yum line" again?
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice