No Match for argument: libXpm-dev

Tagor

Well-Known Member
Mar 6, 2004
193
0
166
I need to install libXpm but I get an error. Does someone know how to fix this?

Thank a lot :)

yum install libXpm-dev
Setting up Install Process
Setting up repositories
update 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
No Match for argument: libXpm-dev
Nothing to do
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,460
22
463
Go on, have a guess
There's no such rpm. What exactly do you want to install? If it's the libXpm libraries, then it depends on your OS:

RHE3/CentOS3 rpm is XFree86-devel
RHE4/CentOS4 rpm is xorg-x11-devel
 

Tagor

Well-Known Member
Mar 6, 2004
193
0
166
That's correct. I want to install libXpm. I am using CentOS 4 (64 bit)
 

Tagor

Well-Known Member
Mar 6, 2004
193
0
166
I am trying to compile apache but I still get this error:
configure: error: libXpm.(a|so) not found.

This is what the yum install said:
yum install xorg-x11-devel
Setting up Install Process
Setting up repositories
update 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package xorg-x11-devel.i386 0:6.8.2-1.EL.13.20 set to be updated
--> Running transaction check
--> Processing Dependency: libSM.so.6 for package: xorg-x11-devel
--> Processing Dependency: libXt.so.6 for package: xorg-x11-devel
--> Processing Dependency: libXpm.so.4 for package: xorg-x11-devel
--> Processing Dependency: libICE.so.6 for package: xorg-x11-devel
--> Processing Dependency: libX11.so.6 for package: xorg-x11-devel
--> Processing Dependency: libXext.so.6 for package: xorg-x11-devel
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xorg-x11-libs.i386 0:6.8.2-1.EL.13.20 set to be updated
--> Running transaction check
--> Processing Dependency: libexpat.so.0 for package: xorg-x11-libs
--> Processing Dependency: libGL.so.1 for package: xorg-x11-libs
--> Processing Dependency: libfontconfig.so.1 for package: xorg-x11-libs
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package expat.i386 0:1.95.7-4 set to be updated
---> Package xorg-x11-Mesa-libGL.i386 0:6.8.2-1.EL.13.20 set to be updated
---> Package fontconfig.i386 0:2.2.3-7 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
xorg-x11-devel i386 6.8.2-1.EL.13.20 base 5.0 M
Installing for dependencies:
expat i386 1.95.7-4 base 69 k
fontconfig i386 2.2.3-7 base 116 k
xorg-x11-Mesa-libGL i386 6.8.2-1.EL.13.20 base 373 k
xorg-x11-libs i386 6.8.2-1.EL.13.20 base 2.6 M

Transaction Summary
=============================================================================
Install 5 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 8.2 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error: file /usr/share/man/man5/fonts-conf.5.gz from install of fontconfig-2.2.3-7 conflicts with file from package fontconfig-2.2.3-7
 

Tagor

Well-Known Member
Mar 6, 2004
193
0
166
chirpy said:
Do this:

rpm -e --justdb fontconfig

Then run your yum line again.
After running the rpm line I get this:

rpm -e --justdb fontconfig
error: Failed dependencies:
libfontconfig.so.1()(64bit) is needed by (installed) xorg-x11-libs-6.8.2-1.EL.13.20.x86_64
fontconfig = 2.2.3 is needed by (installed) fontconfig-devel-2.2.3-7.x86_64