The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No more mail

Discussion in 'E-mail Discussions' started by LP-Tim, May 3, 2007.

  1. LP-Tim

    LP-Tim Active Member

    Joined:
    Apr 30, 2007
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    I don't know that this is a mail issue, so much as maybe an issue that is just affecting mail the most.

    Everything was working fine on my server yesterday. This morning I woke to find cPanel 11 automatically installed. Sure, great, go on with my day.

    About half an hour ago I realized that I have no mail coming or going. Sure enough, mail sent from any account on the server (through webmail) bounces back with:

    Email sent from my gmail and non-gmail accounts to an account on the server come back with:
    It would seem that I am unable to get out of the box.

    I've been poking around a little and don't see much amiss outright, so if anybody has any ideas where I should even start I'd be most appreciative,
     
  2. LP-Tim

    LP-Tim Active Member

    Joined:
    Apr 30, 2007
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    I see this in exim_paniclog:
    I'm guessing that's not good.
     
  3. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    you may want to just /scripts/eximup --force to see if a fresh setup gets your mail working again.
     
  4. LP-Tim

    LP-Tim Active Member

    Joined:
    Apr 30, 2007
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Just tried it. Still no good. Results:

     
  5. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    so I take it your email is down ?? you could try this

    rm /etc/exim.conf
    rm /etc/exim.conf.local

    then /scripts/eximup --force ..see if the syntax error is gone. If that doesn't help try /scripts/upcp --force and the eximup again. If you can get clean default configuration files it should work.
     
  6. LP-Tim

    LP-Tim Active Member

    Joined:
    Apr 30, 2007
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    cPanel auto-update breaks my mail, rpmws saves my butt.

    Removing the config worked beautifully, thank you.
     
  7. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    back woods of NC, USA
    glad it helped you :)
     
  8. mctDarren

    mctDarren Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    664
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    New Jersey
    cPanel Access Level:
    Root Administrator
    D'oh! Had my first complaint this morning about the update to 11. Getting same thing, but my conf passes test... mayhaps I need to add the symlink in manually?
    Code:
    Configuration file passes test!  New configuration file was installed.
    chown: failed to get attributes of `/etc/exim.crt': No such file or directory
    chown: failed to get attributes of `/etc/exim.key': No such file or directory
    
    Added: Weird. Symlinks are there, files linked to are there. Yet still getting error message:
    Would seem like a permissions error on the files themselves? In /etc they are perm'd mailnull:mail and in linked directory they are perm'd root:root...
     
    #8 mctDarren, May 4, 2007
    Last edited: May 4, 2007
  9. mctDarren

    mctDarren Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    664
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    New Jersey
    cPanel Access Level:
    Root Administrator
    On our boxes, it was a permission problem with the files in /var/cpanel/ssl/exim. They should be owned by mailnull:mail. I guess in the copy over process in upgrading to v11 they were set to root:root. Changing permissions ended our problems and eliminated the error message above when forcing exim to reinstall. All is right with the world. Except for spiders. Those are still nasty little eight legged harbingers of death...
     
  10. FeeL

    FeeL Well-Known Member

    Joined:
    Apr 17, 2004
    Messages:
    135
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Rio de janeiro
    cPanel Access Level:
    Reseller Owner
  11. bazzi

    bazzi Well-Known Member

    Joined:
    May 23, 2004
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    I had the same problem.
    removing /etc/exim.conf en /etc/exim.conf.local changed it.

    When you look at WHM you see you have a lot more options at exim configuration. Thats I think the main problem, some of us had already built in some of that standard functions.

    So move your old exim.conf(.local) to another location and use the new exim configuration for the basic ACL's. Than insert your own ACL's from your old exim.conf and check every ACL for compatibality. (So be smart, do one ACL at the time...)
     
Loading...

Share This Page