The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No more /scripts/upcp emails since a couple of days ago

Discussion in 'E-mail Discussions' started by ccccanada, Feb 8, 2004.

  1. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Hello!

    Has anyone stopped receiving those /scripts/upcp emails since a couple of days ago?

    I used to get them every night and was always glad when when I got the last of them for that day.

    Since a few days now I dont get them from any of our servers any more till i received a bounced email today that went as follows:

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    root@server.myserver.com
    All deliveries are handled by MailScanner

    Return-path: <root@server.myserver.com>
    Received: from root by server.myserver.com with local (Exim 4.24)
    id 1ApHhS-0006bk-3l
    for root@server.myserver.com; Sat, 07 Feb 2004 02:56:45 +0100
    From: root@server.myserver.com (Cron Daemon)
    To: root@server.myserver.com
    Subject: Cron <root@server> /scripts/upcp
    X-Cron-Env: <SHELL=/bin/sh>
    X-Cron-Env: <HOME=/root>
    X-Cron-Env: <PATH=/usr/bin:/bin>
    X-Cron-Env: <LOGNAME=root>
    Message-Id: <E1ApHhS-0006bk-3l@server.myserver.com>

    Has something changed that this email now goes to root instead of the server contact email address??

    Thanks for any help.
     
  2. SkyfireMike

    SkyfireMike Member

    Joined:
    Aug 7, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    The same thing's happening on my server and another server I administer. Any heads-up, CPanel gurus?

    Mike
     
  3. Noldar

    Noldar Well-Known Member

    Joined:
    Jun 26, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ponchatoula, LA
    If you're running MailScanner add the following line to /etc/exim.conf:

    queue_only_override = false

    You'll need to add this manually. Do not use the exim config editor in WHM.

    Richard
     
  4. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Thank you Richard could you please tell me where to add this in exim.conf??
     
  5. Noldar

    Noldar Well-Known Member

    Joined:
    Jun 26, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ponchatoula, LA
    It goes at the very top of your exim.conf so that it should look something like this:
    Code:
    #!!# cPanel Exim 4 Config
    
    spool_directory = /var/spool/exim_incoming
    queue_only = true
    queue_only_override = false
    
    Richard
     
  6. SkyfireMike

    SkyfireMike Member

    Joined:
    Aug 7, 2003
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Perfect! I made that change last night, and hey, look, my cron mail showed up!

    Thanks a lot!

    Mike
     
  7. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Thank YOU!!!

    It works great now.
     
  8. Dreamer

    Dreamer Well-Known Member

    Joined:
    Jun 23, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bulgaria
    Hi Richard,

    What are these doing and I don't see them on the top, should I? (I have mailscanner):

    spool_directory = /var/spool/exim_incoming
    queue_only = true

    Thanks
     
  9. Noldar

    Noldar Well-Known Member

    Joined:
    Jun 26, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ponchatoula, LA
    Hi Dreamer,

    Are you looking in the exim config editor in WHM or at the actual exim.conf file? You won't see them in WHM. The lines get added to the exim.conf file by Cpanel when it detects that MailScanner is installed.

    For MailScanner to work with Exim you have to have two mail queues and two Exim processes. All email received by your server is placed in the incoming queue, then gets scanned by MailScanner and placed in the outgoing queue to be delivered by Exim.

    Here's a link that explains how MailScanner works with Exim. Some of the file and directory names are different, but it explains the concept well.

    http://www.sng.ecs.soton.ac.uk/mailscanner/install/exim.shtml

    Richard
     
  10. Dreamer

    Dreamer Well-Known Member

    Joined:
    Jun 23, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bulgaria
    Hi Richard,

    I am looking at the exim.conf file. I've installed mailscanner from layer1, the one bundled with ClamAV. However, I searched again and both of those lines are not there. From the link you provided I see what are used they for, however I am not sure should I have them 100% in cPanel.

    I am using RH9 with latest 8.8.0.S74.

    Thanks :)
     
  11. Noldar

    Noldar Well-Known Member

    Joined:
    Jun 26, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ponchatoula, LA
    Hi Dreamer,

    I didn't use the install from layer1, so I'm not familiar with how it sets up MailScanner. You should have two Exim config files in your /etc directory. You could try the following to try and find which file you need to modify.
    Code:
    cd /etc
    grep queue_only *
    
    Hopefully that should find the needed file.

    Richard
     
  12. kris1351

    kris1351 Well-Known Member

    Joined:
    Apr 18, 2003
    Messages:
    963
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Lewisville, Tx
    I thought my spam rules were messing this up. I wasn't getting cron messages at all after that last update. Thanks for the info.
     
  13. BigBamboo

    BigBamboo Active Member

    Joined:
    Jan 5, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Richard.
    Would adding the line right at the top in the WHM exim advanced editor cause problems?
     
  14. Dreamer

    Dreamer Well-Known Member

    Joined:
    Jun 23, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bulgaria
    Hello Richard,

    I've added the rest. It seems that cPanel Pro have removed them. That's why I was not getting virus notices, but now I do.

    Thanks again :)
     
  15. BigBamboo

    BigBamboo Active Member

    Joined:
    Jan 5, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Tested it with WHM exim configuration, the generated exim.conf looks like this:

    #!!# cPanel Exim 4 Config

    spool_directory = /var/spool/exim_incoming
    queue_only = true


    # added following line to get cron notifications back (noldar tip)
    queue_only_override = false


    Issues with setting it through WHM could be arised by other processes adding lines in between queue_only and queue_override?
     
  16. Noldar

    Noldar Well-Known Member

    Joined:
    Jun 26, 2002
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ponchatoula, LA
    Hi BigBamboo,

    The problem with adding it through WHM is that it will also add it to your exim_outgoing.conf. I don't know if that will cause a problem or not. It may not since queue_only is not set, but I haven't tried it.

    Richard
     
  17. BigBamboo

    BigBamboo Active Member

    Joined:
    Jan 5, 2004
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Thank you Richard, I hadn't figured out that exim had an incoming and an outgoing conf ;c)

    I guess this also answers my question in this thread [http://forums.cpanel.net/showthread.php?s=&postid=93345#post93345] as I'm trying to disable RBL/DNSBL filtering on outgoing mail.
    I'll probably have to directly edit the exim conf files instead of using WHM... And set the rights on those files so that cPanel doesn't overwrite them ;c)
     
  18. pipo

    pipo Member

    Joined:
    Nov 4, 2003
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Quebec, Canada
    I personnaly never had upcp email since I switched my server from redhat to freebsd. This email comes back when I upgraded my freebsd cpanel version to the last stable tree, R72 of 8.8.0.
     
  19. linuxhostuk

    linuxhostuk Registered

    Joined:
    Jun 12, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Just a note

    I know im posting to an old thread but i don't really care :P

    Right to the point,

    My Cron Emails are not getting through, so i uninstalled mailscanner to no avail, but when i SSH'd and did LOCATE mailscanner, it found files in loads of places even though i did the proper ./uninstall

    Also when i reboot exim after adding the queue_only_override = false exim throws errors at me which puts me on edge a little as i have lots of clients on this server and having exim pack up isnt a great start.

    I don't know what to do.

    Any Ideas?

    Chris.
     
Loading...

Share This Page