The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No mySQL db after site transfer

Discussion in 'General Discussion' started by BluAzn, Feb 15, 2009.

  1. BluAzn

    BluAzn Registered

    Joined:
    Sep 14, 2005
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello there,

    I have a problem on my server, I am copying sites over to my server and it seems like the databases are missing. The site content has copied over, only the database itself isn't. Before it worked fine with the v11.20 but after I have upgraded into the latest version, the db has gone missing.

    Please give me solutions to this matter.

    Thank you,
     
  2. fedlerner

    fedlerner Active Member

    Joined:
    Oct 31, 2007
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Argentina
    Hi,
    You can scp the databases from one server to another... Do this on the server from where you're transferring the accounts.
    Code:
    cd /var/lib/mysql
    scp -r CPUSER_* root@SERVER:/var/lib/mysql/
    Where CPUSER is the cPanel user, and SERVER is the hostname or IP of the server you're transferring the accounts to.
    After doing this, make sure that the folder & files are owned by mysql:mysql
    If it's many users, you could try coping the whole mysql folder (Not sure if they are MySQL configuration files on it, so first make sure they aren't)..

    You should open a ticket about the transfer script issue.
     
Loading...

Share This Page