No option to build with Apache 2.2.4?

Gordon Rankin

Member
Sep 28, 2012
6
0
1
London, United Kingdom, United Kingdom
cPanel Access Level
Root Administrator
For reasons I won't go into we have a requirement to use Apache 2.2.4 or above.

The latest version of EasyApache (v3.18.16) supports versions 2.2.24 and 2.4.4. Unfortunately certain modules we need are not yet supported by Apache 2.4 and one in particular requires 2.2.4 or above.

Now I seem to recall Easy apache having the option to install 2.2.4 at some point in the past but it seems to have gone now.

Is there any way to either dowgrade Easy apache in order to install Apache 2.2.4 or above. Or is there any other way to use Easy Apache to build our required version.

Thanks in advance.
 

Infopro

Well-Known Member
May 20, 2003
17,113
507
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
Someone from the EasyApache team will be by to properly answer this. I just wanted to ask what you see on the Apache Version page right now?

On my EDGE server I'm running 2.2.24 right now and I see these listed:
Apache 1.3.42 END OF LIFE
Apache 2.0.64
Apache 2.2.24
Apache 2.4.4 EXPERIMENTAL
 

mtindor

Well-Known Member
Sep 14, 2004
1,363
65
178
inside a catfish
cPanel Access Level
Root Administrator
Forgive me if I'm misundertanding, but you say that you [rightfully] see options in EA to compile 2.2.24 and 2.4.4. In addition, you say that you need Apache 2.2.4 or above.

Apache 2.2.4 < Apache 2.2.24 < Apache 2.4.4

a. Apache 2.2.24 qualifies as "Apache 2.2.4 or above"
b. Apache 2.2.24 qualifies for "one in particular requires 2.2.4 or above"

So I have to ask, what's the problem with just using Apache 2.2.24 ? It seems to meet your requirement of not being 2.4.x and of being "2.2.4 or above".

Mike




For reasons I won't go into we have a requirement to use Apache 2.2.4 or above.

The latest version of EasyApache (v3.18.16) supports versions 2.2.24 and 2.4.4. Unfortunately certain modules we need are not yet supported by Apache 2.4 and one in particular requires 2.2.4 or above.

Now I seem to recall Easy apache having the option to install 2.2.4 at some point in the past but it seems to have gone now.

Is there any way to either dowgrade Easy apache in order to install Apache 2.2.4 or above. Or is there any other way to use Easy Apache to build our required version.

Thanks in advance.
 

cPanelKevinS

Member
Staff member
Mar 7, 2013
8
0
1
Apache 2.2.4 was released over six years ago, and there have been many updates since then. Even if you get hold of a copy of 2.2.4, we strongly recommend against using it, as it contains several security vulnerabilities that were corrected in later releases. The complete change log for the 2.2 series is here:

http://www.apache.org/dist/httpd/CHANGES_2.2

Version 2.2.24, provided in the current version of EasyApache, is the latest in the 2.2 series, and is almost certainly what you want.