Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED No response from subprocess

Discussion in 'General Discussion' started by caroseuk, Dec 14, 2016.

Tags:
  1. caroseuk

    caroseuk Member

    Joined:
    Aug 4, 2015
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    United kingdom
    cPanel Access Level:
    Root Administrator
    Good Morning,

    We have started getting Internal Server Errors within WHM 11.54,

    Upon inspecting logs, we see this:

    Code:
    [2016-12-14 11:40:41 +0000] info [cpsrvd] Internal Server Error: "GET /cpsess1667129505/scripts2/getnslist?domain=&useregns=0 HTTP/1.1" 500 No response from subprocess (whostmgr (whostmgr2)): The subprocess ended prematurely because it received the “SEGV” (11) signal.
    
    Version Mismatch - Built with version 50010020, library used is version 50020022
    Also looking at the latest upcp log this is appearing to fail with the following errors:


    Code:
    [2016-12-14 12:29:31 +0000]   Downloading http://httpupdate.cpanel.net/RPM/11.48/centos/7/x86_64/MySQL55-server-5.5.52-1.cp1148.x86_64.rpm
    [2016-12-14 12:29:34 +0000] ***** FATAL: Digest for http://httpupdate.cpanel.net/RPM/11.48/centos/7/x86_64/MySQL55-server-5.5.52-1.cp1148.x86_64.rpm is different from expected (got hash 62931a94841a1c9e0684908836dcd0c35620ddd96d8219f9e25105d5fc7f8a39ed08b780fba2b9a09cf63c87218b602504f54e46de20eb139f93cb3ebc35f463; expected hash 3978c8d9713353e01b1dee9d6c381c34a0cdbdf809ae0aacc508f0ac24a8a758b3fb03218569937f6abcf0890959247b8a4593d0b0fe60658d21986a2b72bf17; mirror IP 31.22.112.31) at /usr/local/cpanel/scripts/updatenow.static-cpanelsync line 31783.
    [2016-12-14 12:29:34 +0000]   The Administrator will be notified to review this output when this script completes
    We are running WHM on CentOS 7.3

    Can anyone advise us on how to fix this? We are unable to reach parts of WHM..
     
    #1 caroseuk, Dec 14, 2016
    Last edited: Dec 14, 2016
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Please post the output from the following commands:

    Code:
    cat /usr/local/cpanel/version
    arch
    Also, could you try running the "/scripts/upcp --force" command and let us know if the issue persists?

    Keep in mind that cPanel version 54 is nearing EOL status:

    cPanel Long-Term Support - Documentation - cPanel Documentation

    I recommend updating to a newer version at your earliest convenience.

    Thank you.
     
  3. caroseuk

    caroseuk Member

    Joined:
    Aug 4, 2015
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    United kingdom
    cPanel Access Level:
    Root Administrator
    Hi Michael, Output below:
    Code:
    cat /usr/local/cpanel/version
    
    11.54.0.15
    
    arch
    
    x86_64
    We haven't tried running upcp with --force. Will this break anything? This is a production server.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    cPanel updates should not break any services, but I encourage you to open a support ticket using the link in my signature if you'd like us to complete the update on your behalf. You can post the ticket number here and we can update this thread with the outcome.

    Thank you.
     
  5. caroseuk

    caroseuk Member

    Joined:
    Aug 4, 2015
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    United kingdom
    cPanel Access Level:
    Root Administrator
    Thanks Michael, we will register with the support portal now.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    To update, this relates to a bug that was fixed, with the resolution backported into cPanel version 54.0.32:

    Fixed case CPANEL-9827: Update cpanel-perl-514-Compress-Raw-Lzma to 2.068-2.cp1146.

    Updating cPanel to the latest version on the version 54 build tier should address the issue.

    Thank you.
     
  7. caroseuk

    caroseuk Member

    Joined:
    Aug 4, 2015
    Messages:
    24
    Likes Received:
    5
    Trophy Points:
    3
    Location:
    United kingdom
    cPanel Access Level:
    Root Administrator
    Hi Michael, We ended up doing the upcp --force command and updated to version 60 build 28. Had a few issues with old tailwatchd process running but we killed it and WHM started the newer process.

    All seems to be working great now.

    Thanks!
     
    cPanelMichael likes this.
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
  9. paulysanju

    paulysanju Registered

    Joined:
    Dec 16, 2016
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Kerala
    cPanel Access Level:
    Website Owner
    I also have get that error now it is cleared
     
    cPanelMichael likes this.
Loading...

Share This Page