The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No space left on device (Apache error) - but there was

Discussion in 'EasyApache' started by jeroman8, Oct 18, 2008.

  1. jeroman8

    jeroman8 Well-Known Member

    Mar 14, 2003
    Likes Received:
    Trophy Points:

    Anyone know why this happens ?

    Apache is down due to "No space left on device".
    It say so in apache error log.

    But listed i WHM there is more than 1GB left on /usr and no
    other partion is full.
    I even removed log files and other stuff so 1GB more was free.

    /scripts/restartsrv_httpd and service httpd restart does not work.
    Error still say no space left on device.

    After a reboot it works OK.

    Why did I have to reboot the machine so apache (or system)
    would see that it's not full ?

    Just wanna know for the future.

  2. sampride

    sampride Member

    Jul 8, 2005
    Likes Received:
    Trophy Points:
    Run this as root:

    ipcs -s | grep nobody | perl -e 'while (<STDIN>) { @a=split(/\s+/); print `ipcrm sem $a[1]`}'

    It will fix this error.
  3. rhenderson

    rhenderson Well-Known Member

    Apr 21, 2005
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    It happens because of too many semaphores, run
    # ipcs -s

    You should get the following:

    ------ Semaphore Arrays --------
    key semid owner perms nsems
    0x00000000 12779528 nobody 600 1
    0x00000000 12812297 nobody 600 1
    0x00000000 12845066 nobody 600 1
    0x00000000 12877835 nobody 600 1
    0x00000000 12910604 nobody 600 1
    0x00000000 12943373 nobody 600 1
    0x00000000 12976142 nobody 600 1
    0x00000000 13008911 nobody 600 1
    0x00000000 13041680 nobody 600 1

    But I bet you get a lot more and the owners are your clients.

    That might clear it up enough for a restart but it will not clear the semaphores owned by others than nobody, since your just searching for nobody. Do that wait a few hours and try to restart apache and it will fail with your error again. So it is not a fix, more like a bandaid or an emergency restart.

    We ran into this and it was very frustrating for us to track down. We found that when you build apache if you go to the exhaustive list and have Mod FCGID - fastcgi support and Fastcgi (This option will make the following changes to your profile prior to the build) Enables: Mod FCGID, it will create a lot more semaphores with it enabled, it will create semaphores for anyone using crons in a certain way, then if you have anything that restarts apache it will fail with your error.

    Rebuilding apache and taking that option out corrected our problem, which is identical to your problem.
    Good Luck!!
    #3 rhenderson, Oct 22, 2008
    Last edited: Oct 22, 2008

Share This Page