The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No Such User Here, of the root user

Discussion in 'E-mail Discussions' started by kimxt, May 29, 2013.

  1. kimxt

    kimxt Member

    Joined:
    Mar 4, 2013
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi

    Sorry if this is going the wrong place.

    Dont know really how to put this. But my server is trying to send several mails from root user.
    But when i run a "Mail Delivery Reports" its saying:

    root@xxxx.xxxx.xx
    May 30, 2013 1:04:01 AM

    root@xxxx.xxxx.xx
    1UhpQK-0004ES-5p
    No Such User Here

    Seems like the user root dosent have a mail account or something?
    This is happening every now and then, and i guess about 10 times every hour.

    Can't find anything wrong in any logs, but dont know anything about this problem and dont know where to begin to look to be honest. I have been trying to google for some time, but cant figur out what this stuff is.

    Seems its log mails, ban mails from firewall and other system mails root@ is trying to send me.


    I have put a mail adress in "Edit System Mail Preferences" under root's mail, nobody's mail and cpanel's mail.


    OR what else might be happening here, or be the problem?
     
    #1 kimxt, May 29, 2013
    Last edited: May 29, 2013
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,808
    Likes Received:
    667
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please check to see if the forwarding email address for root that you configured via "WHM Home » Server Contacts » Edit System Mail Preferences" is valid. Are you able to send emails to this address manually? You can also confirm that it's set properly by checking to see if it's populated in the following file:

    Code:
    # /root/.forward 
    In addition, check to make sure the hostname of the server resolves to the correct IP address.

    Thank you.
     
  3. kimxt

    kimxt Member

    Joined:
    Mar 4, 2013
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    "Please check to see if the forwarding email address for root that you configured via "WHM Home » Server Contacts » Edit System Mail Preferences" is valid"
    All is correct there.

    the code or file you gave me also give's me the correct e-mail.

    "In addition, check to make sure the hostname of the server resolves to the correct IP address."
    all there is as it should be.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,808
    Likes Received:
    667
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Could you open a support ticket so we can access your server and investigate further?

    Submit A Ticket

    Please post the ticket number here so we can update this thread with the resolution.

    Thank you.
     
  5. kimxt

    kimxt Member

    Joined:
    Mar 4, 2013
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    ticket 4170545
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,808
    Likes Received:
    667
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I had a chance to review this ticket. I wanted to update this thread to note the issue was related to the domain name associated with the contact address being in the /etc/localdomains file. As email for this domain name is handled remotely, it had to be moved to the /etc/remotedomains file. This is completed by modifying the "Email Routing" settings in "WHM Home » DNS Functions » Edit DNS Zone" to "Remote Mail Exchanger".

    I also wanted to answer an additional concern you mentioned. You asked if there was a method to control which alerts from cPanel are emailed to you. There is an option where many of these alerts can be modified. It's located at:

    "WHM Home » Server Contacts » Contact Manager"

    Keep in mind that some alerts (e.g. Process Usage reports from LFD) are the result of third-party applications, so you have to change their alert destinations manually.

    Thank you.
     
Loading...

Share This Page