Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No symlink protection detected?

Discussion in 'Security' started by thanasis, Feb 6, 2018.

  1. thanasis

    thanasis Active Member

    Joined:
    Nov 24, 2017
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Hello,

    at cPanel Security Advisor i have "No symlink protection detected"
    I checked the documentation at KernelCare Documentation and installed the KernelCare with the command:
    Code:
    curl -s https://repo.cloudlinux.com/kernelcare/kernelcare_install.sh | bash
    
    Also i checked if patches applied run:
    /usr/bin/kcarectl --info

    Then i did manually update:
    /usr/bin/kcarectl --update

    and checked check current kernel compatibility with KernelCare:
    Code:
    curl -s https://raw.githubusercontent.com/iseletsk/kernelchecker/master/py/kc-compat.py | python
    
    BUT when i run again the cPanel Security Advisor i had again "No symlink protection detected" and a new warning :

    Code:
    The system kernel is at version “3.10.0-693.11.6.el7”, but is set to boot to version “3.10.0-693.17.1.el7.x86_64”.
    You must take one of the following actions to ensure the system is up-to-date:
    Wait a few days for KernelCare to publish a kernel patch.
    Reboot the system.
    I did a reboot but still have the same error and warning...
    Any help?
     

    Attached Files:

    #1 thanasis, Feb 6, 2018
    Last edited by a moderator: Feb 6, 2018
  2. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    27
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
  3. thanasis

    thanasis Active Member

    Joined:
    Nov 24, 2017
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Hello, my cPanel version is v68.0.28

    I have another vps server, with same configuation (centos 7, cpanel v 68.0.28), but i don't see this error...
     
  4. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    27
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    Are both using the free patch set? CPANEL-17016 specifically concerns support for the free patch. You can verify the free patch is in use as below:
    Code:
    # kcarectl --info|grep free
    kpatch-description: 1-free;
    
     
    thanasis likes this.
Loading...

Share This Page