Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

No UTF-8 in Horde due to serious httpd bug

Discussion in 'General Discussion' started by gmb, Jun 1, 2007.

  1. gmb

    gmb Registered

    Joined:
    Jun 1, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    Hi,

    Horde webmail is completely lacking it's usual UTF-8 capabilities, due to serious bug within Cpanel's httpd.

    In standard (non-cpanel) installation on Linux, Horde is getting the following PHP variable, which it uses to verify UTF-8 support in web browser:

    _SERVER["HTTP_ACCEPT_CHARSET"] ISO-8859-1,utf-8;q=0.7,*;q=0.7

    However, Cpanel's httpd/PHP is not passing this variable to Horde, which means Horde falls back to ISO-8859-1 codepage and lacks all UTF-8 capabilities.

    This is a serious bug, since no multilingual emails can be written in Horde.

    --gmb
     
    #1 gmb, Jun 1, 2007
    Last edited: Jun 1, 2007
  2. Daniel15

    Daniel15 Well-Known Member

    Joined:
    Oct 7, 2006
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
  3. gmb

    gmb Registered

    Joined:
    Jun 1, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    151
    Done, bug ID is 5487.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice