no version information available (required by /usr/bin/php)

golden_eyes

Well-Known Member
Aug 9, 2010
88
1
58
Hey,

I've been getting errors recently such as the one below:

Code:
[Tue Apr 26 03:23:28 2011] [error] [client 94.97.182.22] /usr/bin/php: /opt/xml2/lib/libxml2.so.2: no version information available (required by /usr/bin/php)
[Tue Apr 26 03:23:28 2011] [error] [client 94.97.182.22] /usr/bin/php: /opt/xml2/lib/libxml2.so.2: no version information available (required by /usr/bin/php)
[Tue Apr 26 03:23:28 2011] [error] [client 94.97.182.22] /usr/bin/php: /opt/xml2/lib/libxml2.so.2: no version information available (required by /usr/bin/php)
[Tue Apr 26 03:23:28 2011] [error] [client 94.97.182.22] /usr/bin/php: /opt/xml2/lib/libxml2.so.2: no version information available (required by /usr/bin/php)
[Tue Apr 26 03:23:28 2011] [error] [client 94.97.182.22] /usr/bin/php: /opt/xml2/lib/libxml2.so.2: no version information available (required by /usr/bin/php)
I ran locate libsms2.so I found

Code:
/home/cpeasyapache/src/libxml2-2.7.8/.libs/libxml2.so.2
/home/cpeasyapache/src/libxml2-2.7.8/.libs/libxml2.so.2.7.8
/opt/xml2/lib/libxml2.so.2
/opt/xml2/lib/libxml2.so.2.7.6
/opt/xml2/lib/libxml2.so.2.7.8
/usr/lib/libxml2.so.2
/usr/lib/libxml2.so.2.6.26
/usr/lib64/libxml2.so.2
/usr/lib64/libxml2.so.2.6.23
/usr/lib64/libxml2.so.2.6.26
/usr/local/cpanel/lib/libxml2.so.2
/usr/local/cpanel/lib64/libxml2.so.2
/usr/local/cpanel/src/3rdparty/gpl/libxml2-2.6.23/.libs/libxml2.so.2
/usr/local/cpanel/src/3rdparty/gpl/libxml2-2.6.23/.libs/libxml2.so.2.6.23
and

Code:
[email protected] [/opt/xml2/lib]# ls -lh
total 15M
drwxr-xr-x 3 root root 4.0K Apr 21 03:24 ./
drwxr-xr-x 6 root root 4.0K Nov 21 20:08 ../
-rw-r--r-- 1 root root 6.3M Apr 21 03:24 libxml2.a
-rwxr-xr-x 1 root root  930 Apr 21 03:24 libxml2.la*
lrwxrwxrwx 1 root root   16 Apr 21 03:24 libxml2.so -> libxml2.so.2.7.8*
lrwxrwxrwx 1 root root   16 Apr 21 03:24 libxml2.so.2 -> libxml2.so.2.7.8*
-rwxr-xr-x 1 root root 4.0M Nov 21 20:08 libxml2.so.2.7.6*
-rwxr-xr-x 1 root root 4.0M Apr 21 03:24 libxml2.so.2.7.8*
drwxr-xr-x 2 root root 4.0K Apr 21 03:24 pkgconfig/
-rw-r--r-- 1 root root  208 Apr 21 03:24 xml2Conf.sh
any help please?
 

golden_eyes

Well-Known Member
Aug 9, 2010
88
1
58
They cleared out the files in /opt and rebuilt apache/php with the last used profile to force easy apache to re-download these files.
What is the steps to do that? for sure I cant delete the content of /opt, I would appreciate if you can help with this matter and give me the steps including the easyapache.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Simply try moving /opt/xml2/ first:

Code:
mv /opt/xml2 /opt/xml2.bak
Then re-run EasyApache using either WHM > EasyApache (Apache Update) or root SSH /scripts/easyapache --force
 

sehh

Well-Known Member
Feb 11, 2006
579
6
168
Europe
Interestingly, I run on this problem after I run EasyApache to upgrade to the latest php version. Suddenly WHM wasn't accessible and the php command used by WHM/cPanel would produce the same errors as above (but not the php command used by the system).

I removed the old /opt/xml2 and I'm recompiling right now.

This guy had the same problem and solved it by removing the xml2 directory:
https://myeasylinux.wordpress.com/2011/08/27/no-version-information-available-required-by-php/
 

sehh

Well-Known Member
Feb 11, 2006
579
6
168
Europe
Unfortunately it didn't help me, the system php binary is fine but the /var/cpanel/3rdparty/bin/php used by WHM/cPanel is not and continues to produce the same errors.

I've simple copied the system php binary over that and everything seems to work fine now.

(but I wasn't supposed to do that, was I?)
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Correct, you shouldn't have copied the system binary to /vrcpanel/3rdparty/bin/php location, since the cPanel version has major differences. Can you try running this command to see if it works (it will replace the binary you copied):

Code:
/scripts/makecpphp --force
 

sehh

Well-Known Member
Feb 11, 2006
579
6
168
Europe
cPanelTristan,

thank you for that, I tried it and I also recompiled via EasyApache all over again (but first I removed the xml2 dir) and now everything works, the cPanel php binary no longer produces errors.

Unfortunately, I have another problem now, it appears that the recent roundcube 0.6 release is broken on my system. It was automatically updated on the 22nd (a few days ago) and since then roundcube produces an error "service not available" error 501. I've posted the issue on a new thread.