The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No VirtualHosts

Discussion in 'General Discussion' started by uneedawebsite, Nov 5, 2007.

  1. uneedawebsite

    uneedawebsite Active Member

    Joined:
    Apr 14, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I am getting the following error from Apache:

    [Mon Nov 05 08:50:02 2007] [warn] NameVirtualHost 67.15.16.121:443 has no VirtualHosts
    [Mon Nov 05 08:50:02 2007] [warn] NameVirtualHost 67.15.16.123:443 has no VirtualHosts
    [Mon Nov 05 08:50:02 2007] [warn] NameVirtualHost 67.15.16.7:443 has no VirtualHosts

    I checked my httpd.conf file and do see a VirtualHost entry for each of those IP's for both port 80 and port 443.

    I am running Apache 2.2 and CPanel R17853. This problem started when I upgraded to R17853.

    Any ideas on how to fix this?

    Mark
     
    #1 uneedawebsite, Nov 5, 2007
    Last edited: Nov 5, 2007
  2. uneedawebsite

    uneedawebsite Active Member

    Joined:
    Apr 14, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    It seems that I found a fix for this. In the section where all the NameVirtualHost (s) are defined, I commented out the lines for the three hosts on port 443 that were giving me trouble.

    The three hosts are still working with https, so it appears (at least to me) that the NameVirtualHost entry for these is not needed.

    Mark
     
  3. goldclub

    goldclub Member

    Joined:
    Nov 20, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1

    Mark please give me more details on this. httpd is failing to start for me and this could help if I could comment out like that
     
  4. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    You sure those IPs are not listed twice with :443 in the httpd.conf?
     

Share This Page