The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

no website configured error after IP address addition

Discussion in 'General Discussion' started by SteveC, Apr 17, 2006.

  1. SteveC

    SteveC Member

    Joined:
    Aug 30, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    My server was assigned an additional IP address, but I seem to be having problems getting the web site it's assigned to to work. Now when I browse to the site I get the standard cPanel "There is no website configured at this address." error message. Thankfully the site is still in development so I'm not losing traffic due to this.

    Here's what I've done:

    • I added the IP address in WHM using the "Add a New IP Address" function.
    • Then, I used the "Change a Site's IP Address" function to assign the IP address to the specific site. So far, so good.
    • I double checked the DNS records to make sure they updated with the new IP address and they updated with no problems (I even logged in via SSH and checked the httpd.conf file as well).
    • I tried to browse to the site in IE, but got the cPanel error message.
    • I waited a couple hours just for the heck of it and tried again. Same thing.
    • I checked the "Show IP Address Usage" and it does show the domain (and its email) is assigned to the new IP address.
    • I did a tracert to make sure it wasn't still trying to go to the old IP address, but the tracert returned the new IP address.
    • I tried logging into cPanel from that domain http://www.domain.com:2082 and that worked. I am able to log into cPanel on that domain. I just can't get the regular web site to work.

    Any ideas of what could be wrong or how to fix it? Any help would be GREATLY appreciated.

    Thanks!
     
  2. SteveC

    SteveC Member

    Joined:
    Aug 30, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Nevermind. It's working now.
     
  3. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    That's caused by trying to reach the site on an IP that wasn't defined in the site's virtual host settings.

    In other words, you can edit the httpd.conf container for the site and add in the extra IP and your site would have worked.

    ie: <VirtualHost 72.128.211.226 72.128.211.214>
    instead of: <VirtualHost 72.128.211.226>

    Or, you could just wait till the old DNS records expire, like you did, and it'll start working again.
     
Loading...

Share This Page