The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nobody@domain.com sending msgs

Discussion in 'General Discussion' started by SupermanInNY, Dec 12, 2004.

  1. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    Hi there,

    When users are using phpBB2 or other boards, the system then sends msgs to notify them that they have a "private message" waiting for them when the such an instance occur.

    Sometimes, the email msgs bounce and then I get these long queues.

    In my Mail Queue I see the following:


    1CdOGd-0003Kw-Ny 3.3K 3h Delete Deliver Now
    nobody@usa.server.com
    1CdOGi-0003L5-ED 2.1K 3h Delete Deliver Now
    nobody@usa.server.com
    1CdOHB-0003LR-Qq 3.5K 3h Delete Deliver Now
    nobody@usa.server.com
    1CdOM6-0003Pe-AG 3.2K 3h Delete Deliver Now
    nobody@usa.server.com
    1CdOMA-0003Pn-CQ 3.2K 3h Delete Deliver Now
    nobody@usa.server.com
    1CdOMF-0003Pt-4m 3.5K 3h Delete Deliver Now
    nobody@usa.server.com
    1CdOMc-0003QJ-DG 2.4K 3h Delete Deliver Now
    nobody@usa.server.com
    1CdONW-0003S8-Vy 3.0K 3h Delete Deliver Now
    nobody@usa.server.com


    What does that mean?
    What will happen if I enable the:

    Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)

    Will that break any scripts?

    thanks,

    -Alon.
     
  2. Host4u2

    Host4u2 Well-Known Member

    Joined:
    Mar 24, 2002
    Messages:
    248
    Likes Received:
    0
    Trophy Points:
    16
    Doing this will stop messages from being sent through php scripts, such as email notifications from your messge boards, etc..

    Read up on phpsuexec to resolve this issue.
     
  3. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    I know it stops the mail() function or something like that, but there is got to be a way to allow sending out mail. Most of the boards have a "Use SMTP" option in them, but I never got to understand how use it so that they can send email from their specific accounts.
    Any pointers?
    I can't lock my users out and now allow them to send mail. I just want to provide for a way to identify who is the one that is mailing.

    -Alon.
     
  4. Host4u2

    Host4u2 Well-Known Member

    Joined:
    Mar 24, 2002
    Messages:
    248
    Likes Received:
    0
    Trophy Points:
    16
    Not only message boards (i.e. phpbb) scripts send messages as "nobody", but actually all (or most) mail sent via php will result in sending as nobody. phpsuexec is the ultimate answer for a resolve to this security-hole. As we have programs on one server that are not compatible with phpsuexec, we done the following to lighten up the mail queue:

    Basically, what we did was change all email accounts default account from :fail: to :blackhole:
    The command to do this is:
    Code:
    replace :blackhole: :fail: -- /etc/valiases/*
    (However this should normally be done in cPanel). This won't stop all frozen messages but it helps.

    Another thing we done was change 'timeout_frozen_after = 7d' in exim.conf to 3d (days) instead of a week. This makes exim remove frozen messages after x number of days.
     
  5. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    I've followed your advice and implemented the suggestions you described.
    However, and this is something that I can "dictate" to my users, I can force them to use a real pop/smtp account to send out mail, and not use the nobody, if they hard code an email account and password.
    But, I'm not that familiar with phpBB or Invision and so I don't know how or where to plug the code that will utilize such an account. I know this is out of the scope of the cPanel discussion, but it seems that this is where a greater interest will rise to implement/force it on the users.

    -Alon.
     
  6. Trigger

    Trigger Well-Known Member

    Joined:
    May 17, 2003
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Brisbane
    You are better of using this fix http://forums.cpanel.net/showthread.php?t=31615. the forums should be sending out using the admin email address but because of the changes in exim the header will be set as nobody@sever.domain.com so any bounced email generated from the server will just sit in the queue until they time out.

    This fix works great and any bounces will get returned to the "From" address used in the emails rather than clogging up the queue.
     
  7. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16

    Well.. at least now I know what to do:

    1. I can trace the user/forum that sent out the msgs, by looking at the content of the message and find the forum that is sending it out. I found the option to choose to use the SMTP in the phpBB board, and it needs to be set to localhost.

    2. I'm running with phpSuExec Enabled, so I wasn't clear whether the modifications of the Exim will work or not, but if I understand correctly, it can't hurt and it won't affect anything to leave them in.

    3. I followed the other two suggestions in the thread for dropping length of stay in queue and the fail vs. blackhole.

    I hope this will clear some of the 400 and something msgs I have in the queue in the next 3 days.

    Thanks,

    -Alon.
     
  8. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16

    What a weired behaviour I have on my server!
    If I look at:

    /etc/exim.conf

    I have the following entry:


    #!!# ignore_errmsg_errors_after renamed ignore_bounce_errors_after
    ignore_bounce_errors_after = 2d

    # This option cancels (removes) frozen messages that are older than a week.

    timeout_frozen_after = 3d

    But when I look in the WHM--> Service Configuration --> Exim Configuration Editor --> Switch to Advanced Mode I see in the Grey area where I can't write to:

    #!!# ignore_errmsg_errors_after renamed ignore_bounce_errors_after
    ignore_bounce_errors_after = 2d

    # This option cancels (removes) frozen messages that are older than a week.

    timeout_frozen_after = 7d

    AND,.. no surprise, I have msgs of 4 days old in the queue.
    Since my last post here, I've restarted Exim several tims, I even upgraded cPanel from S11 to S15, but to no avail.
    I now have 1027 email msgs in the queue.

    Any suggestions?

    -Alon.
     
  9. Host4u2

    Host4u2 Well-Known Member

    Joined:
    Mar 24, 2002
    Messages:
    248
    Likes Received:
    0
    Trophy Points:
    16
    Yes, but the 1027 messages shouldn't be "frozen" messages more than 3 days old!?!
     
  10. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    Let me rephrase what I have:
    I have lots of msgs that have the following:


    1Ce4Qm-0006wX-8A-H
    mailnull 47 12
    <>
    1102999020 0
    -ident mailnull
    -received_protocol local
    -body_linecount 42
    -allow_unqualified_recipient
    -allow_unqualified_sender
    -frozen 1103066730
    -localerror
    XX
    1
    nqrbgs@racemail.com

    143P Received: from mailnull by bess.myserver.com with local (Exim 4.43)
    id 1Ce4Qm-0006wX-8A
    for nqrbgs@racemail.com; Tue, 14 Dec 2004 06:37:00 +0200
    043 X-Failed-Recipients: selfesteem@clientdomain.com
    031 Auto-Submitted: auto-generated
    057F From: Mail Delivery System <Mailer-Daemon@bess.myserver.com>
    024T To: nqrbgs@racemail.com
    059 Subject: Mail delivery failed: returning message to sender
    046I Message-Id: <E1Ce4Qm-0006wX-8A@bess.myserver.com>
    038 Date: Tue, 14 Dec 2004 06:37:00 +0200

    1Ce4Qm-0006wX-8A-D
    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    selfesteem@clientdomain.com


    ------ This is a copy of the message, including all the headers. ------



    I decided to "clean" it out as I noticed many of these msgs are 68Hrs, 48 Hours,..etc.. so I've changed the 3d to a 1d, I restarted Exim, and then Clicked on the Attempt to Deliver All Now.

    Would that purge all those that are above the 24Hrs?

    -Alon.
     
  11. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    Well.. that didn't do the trick.
    I'm still stuck with all those msgs.
    How can I do a mass purge of messages who are in the queue over 24 hours?

    -Alon.
     
  12. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
    If I drop it to 2d ,.. how often does Exim check and do the clean up?
    Is there a /scripts/cleanfrozenemailmessages or something like that and is ran every ...x amount of hours?
    I would love to run it ... now!

    -Alon.
     
  13. SupermanInNY

    SupermanInNY Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    255
    Likes Received:
    0
    Trophy Points:
    16
     
Loading...

Share This Page