The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nobody in php mail headers

Discussion in 'E-mail Discussions' started by searcher1, Feb 17, 2007.

  1. searcher1

    searcher1 Active Member

    Joined:
    Jul 23, 2005
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London, UK
    Okay,

    As I search more I get even more confused! :confused:

    Basically I send occasional mass mails (to ensure people on one of my sites wish to remain there). As I use a php script the sender appears as 'nobody@xxx.com' etc. I guess that even though I have an SFP (?) set up places (especially) like yahoo decide the mails are not authentic and move them to 'bulk' etc. or even refject them (e.g. Hotmail occasionally).

    The sender appears as 'nobody@my.host.com' (not real of course). The envelope shows the same as the previous sentance too. All I want to do is send mails that for this particular site shows 'me' as the sender. I did read about exim adjustments but I don't want this to be global (if that makes sense at all?).

    My other problem is that WHM is setup fine but I see my 'sender' is the 'host.XXX.com' - Just a little concerned that this would not get through email systems alone as surely it should be 'XXX.com' ?

    Is there some simple definitive answer to this?

    Michael
     
  2. mohit

    mohit Well-Known Member

    Joined:
    Jul 12, 2005
    Messages:
    553
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sticky On Internet
    phpSuExec is the answer

    hi,
    compile Apache with phpSuExec it will run php with your userid and not as nobody.
    there are lot of threads on phpSuExec how to.


    see ya,
    mohit
     
  3. brendanrtg

    brendanrtg Well-Known Member

    Joined:
    Oct 4, 2006
    Messages:
    311
    Likes Received:
    0
    Trophy Points:
    16
    Be very careful when you compile apache with phpSuExec, some scripts MAY NOT run with that enabled.
     
  4. searcher1

    searcher1 Active Member

    Joined:
    Jul 23, 2005
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London, UK
    Thank you for the information - all now working perfectly!! :)
    So easy when you know how (as they say) :D
    Michael
     
  5. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    So what'd you do?
     
  6. searcher1

    searcher1 Active Member

    Joined:
    Jul 23, 2005
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    London, UK
    I iniatially had the problem of WHM telling me the glib install was wrong.
    Looked that up and 'forced' cpanel to run it
    Then merely updated the stuff regarding my inital request for information.
    It now works perfectly - I am happy
    If I'm truthful though I'm thinking cpanel last update went terribly wrong in the way I now see a email address with space used and yet the actual address is empty of mail!

    With me it tends to fail entirely (and I panic big time!) or it works like a dream (which it did this time) :) yay!!

    If I'm to ask a question though - what stable and latest php version should I be running with Apache 1.3.7 and Fedora 3?

    Thank you again
    Michael
     
    #6 searcher1, Feb 18, 2007
    Last edited: Feb 18, 2007
Loading...

Share This Page