The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"nobody" ownership and FTP Permission Problems

Discussion in 'General Discussion' started by USF-Smiley, Jul 26, 2009.

Thread Status:
Not open for further replies.
  1. USF-Smiley

    USF-Smiley Registered

    Joined:
    Jul 26, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have failed at my attempt to move from shared hosting to a dedicated server. With my shared host, I could upload a joomla site and edit files without error. Now that I've started with a dedicated server with cPanel/whm, I don't find it as easy. I do not have ssh experience and am told by my dedicated server provider (the planet) that I have to solve the issue on my own. Here is what the planet said:

    the planet : Ok I see your issue. You are uploading the files as another user or the program installs where the directories are nobody
    the planet : You are trying to change the permissions but the files give that error because they are owned by use nobody.
    the planet : You need to be sure you upload or ftp where the files take the permissions of the directory they are in

    The problem is, I don't know how to have control over how I upload a joomla template via the joomla/administrator. Therefore, don't know where or how to update my cPanel to allow for edits to the files I wish to edit (ie index.php, footer.php, etc).

    Can anyone provide solution in laymans terms? I would prefer to stay with dedicated as I'm now getting about one to two new web hosting customers a week. And, most are joomla sites. So if I cannot get my first joomla site to work, I might just go back to shared hosting until I learn more about setting file permissions for cpanel.

    I will entertain suggestions for subcontractor to assist.

    Looking forward to replies.

    USF-Smiley
     
  2. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    You would need to change the ownership of the user from root:nobody to username:username. You can do this through SSH using the below mentioned command.

    root@server[/home/username/public_html]: chown -R user:user [yourfoldername]

    Please note that the ownership of the public_html should be user:nobody (if suphp is not enabled)

    Once you change the permission, you can able to upload the themes and can able to change the files.
     
  3. johnburk

    johnburk Well-Known Member

    Joined:
    Jun 23, 2006
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    Do NOT use the above script! There is a reason this user has been banned! The above script will really mess your permissions up!
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,450
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I've removed that post and I think we'll close this thread as well, its a few years old. ;)
     
Loading...
Thread Status:
Not open for further replies.

Share This Page