The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nobody@srv02.hostname

Discussion in 'E-mail Discussions' started by noclue, Jan 28, 2008.

  1. noclue

    noclue Registered

    Joined:
    Jan 28, 2008
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi

    I have just got a cPanel server for the first time, I am not using it for DNS or nameserver, I have a PHP script that sends results of a form, it uses mail().

    The emails are not getting through, they end up in the mail queue stating user unknown nobody@srv02.myhostname.com I don't know how to stop it.

    Any help would be appreciated, thanks in advance

    PS in WHM I have ticked the box under tweak settings

    "Prevent the user "nobody" from sending out mail to remote addresses"
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Are you running SuPHP or if you're running PHP as CGI, SuExec? If not, this will prevent the mail from being sent as by default PHP runs as user nobody.
     
Loading...

Share This Page