The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

nobody using lot of memory

Discussion in 'Workarounds and Optimization' started by a24uall, Nov 17, 2010.

  1. a24uall

    a24uall Active Member

    Joined:
    Feb 4, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    haii..

    Top result shows nobody using max memory.
    ==========
    17881 nobody 19 4 252m 43m 5076 S 1.0 4.2 0:04.34 /usr/local/apache/bin/httpd -k start -DSSL
    16019 nobody 19 4 247m 37m 5000 S 0.0 3.7 0:02.96 /usr/local/apache/bin/httpd -k start -DSSL
    32470 nobody 20 4 246m 37m 5000 S 2.4 3.6 0:02.87 /usr/local/apache/bin/httpd -k start -DSSL
    14272 nobody 19 4 245m 36m 5124 S 0.0 3.6 0:02.75 /usr/local/apache/bin/httpd -k start -DSSL
    32516 nobody 19 4 243m 34m 5040 S 2.4 3.4 0:02.53 /usr/local/apache/bin/httpd -k start -DSSL
    14271 nobody 19 4 243m 33m 4888 S 0.0 3.3 0:02.50 /usr/local/apache/bin/httpd -k start -DSSL
    29879 nobody 19 4 242m 33m 4844 S 0.0 3.2 0:02.51 /usr/local/apache/bin/httpd -k start -DSSL
    1665 nobody 19 4 241m 32m 4864 S 0.3 3.1 0:02.18 /usr/local/apache/bin/httpd -k start -DSSL
    32471 nobody 19 4 240m 31m 5104 S 0.0 3.1 0:02.20 /usr/local/apache/bin/httpd -k start -DSSL
    27704 nobody 19 4 240m 31m 4832 S 0.0 3.1 0:01.96 /usr/local/apache/bin/httpd -k start -DSSL
    17542 nobody 21 4 241m 31m 4876 S 0.0 3.1 0:01.78 /usr/local/apache/bin/httpd -k start -DSSL
    11681 nobody 19 4 240m 31m 5036 S 0.0 3.1 0:02.08 /usr/local/apache/bin/httpd -k start -DSSL
    5349 nobody 19 4 240m 31m 4812 S 0.0 3.0 0:01.87 /usr/local/apache/bin/httpd -k start -DSSL
    32519 nobody 19 4 240m 30m 4816 S 0.0 3.0 0:01.85 /usr/local/apache/bin/httpd -k start -DSSL
    32485 nobody 19 4 239m 30m 5044 S 0.0 3.0 0:01.75 /usr/local/apache/bin/httpd -k start -DSSL
    29878 nobody 19 4 239m 30m 5020 S 0.0 3.0 0:01.74 /usr/local/apache/bin/httpd -k start -DSSL
    26006 nobody 19 4 238m 29m 4980 S 0.0 2.9 0:01.44 /usr/local/apache/bin/httpd -k start -DSSL
    17544 nobody 19 4 238m 29m 5036 S 0.0 2.8 0:01.59 /usr/local/apache/bin/httpd -k start -DSSL
    31845 nobody 19 4 237m 28m 5252 S 0.0 2.8 0:01.31 /usr/local/apache/bin/httpd -k start -DSSL
    7595 nobody 19 4 237m 28m 4824 S 0.0 2.8 0:01.45 /usr/local/apache/bin/httpd -k start -DSSL
    1662 nobody 21 4 237m 28m 4888 S 0.0 2.8 0:01.62 /usr/local/apache/bin/httpd -k start -DSSL
    30568 nobody 19 4 237m 28m 4852 S 0.0 2.8 0:01.07 /usr/local/apache/bin/httpd -k start -DSSL
    30569 nobody 19 4 237m 27m 4964 S 0.0 2.7 0:01.33 /usr/local/apache/bin/httpd -k start -DSSL
    21756 nobody 19 4 236m 27m 4996 S 0.0 2.7 0:01.23 /usr/local/apache/bin/httpd -k start -DSSL
    26201 nobody 19 4 236m 27m 4952 S 0.0 2.7 0:01.12 /usr/local/apache/bin/httpd -k start -DSSL
    26200 nobody 19 4 236m 27m 4796 S 0.0 2.7 0:01.17 /usr/local/apache/bin/httpd -k start -DSSL
    30112 nobody 19 4 236m 27m 4960 S 0.0 2.7 0:01.14 /usr/local/apache/bin/httpd -k start -DSSL
    30718 nobody 19 4 236m 26m 4820 S 0.0 2.6 0:01.37 /usr/local/apache/bin/httpd -k start -DSSL
    25807 nobody 19 4 235m 26m 4792 S 0.0 2.6 0:01.48 /usr/local/apache/bin/httpd -k start -DSSL
    27890 nobody 19 4 235m 26m 4848 S 0.3 2.6 0:01.22 /usr/local/apache/bin/httpd -k start -DSSL
    27832 nobody 19 4 236m 26m 4800 S 0.0 2.6 0:01.15 /usr/local/apache/bin/httpd -k start -DSSL
    ======================
    Am running DSO with SUEXEC On.
    I tried with cgi as well with no change
    Tweaked apache as well..

    Can any one give me a clue on how to stop this.

    Thanks
     
  2. RCraft

    RCraft Well-Known Member

    Joined:
    Nov 7, 2010
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Can you give us an outlook on how much traffic is hitting your server when the memory usage is high as well as your apache configuration file?
     
  3. a24uall

    a24uall Active Member

    Joined:
    Feb 4, 2010
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    hai..
    Its a vps
    wt do u mean by server traffic ? Is that the number of httpd connections that comes to server at that time? if so its like below 300 connections with my server having 1+Gb ram.
    Apache conf i will paste it here.. but b4 that can u let me know the tweak that should be done in apache for a VPS ?
     
  4. GaryT

    GaryT Well-Known Member

    Joined:
    May 19, 2010
    Messages:
    321
    Likes Received:
    3
    Trophy Points:
    16
    For your own safety I would 100% get of DSO and switch to CGI atleast, CGI is more secure than DSO, Probably same speed and it should control the memory much better. Now its completly hard to tell at this moment whats going on as not much information is given.

    Now I'm not sure on your websites or what you run of if you host, But if I was you and I only had the one website I would consider switching to suPHP.

    This way the processes will or should run as the account name so its better for tracking what the cause of any problems are butthis can be difficult setting permissions ans such.

    To narrow things down, When you get such processes again or high loads run the following commands and post back, You should get more info after giving the stats needed.

    Check amount of connections to apache:
    Check amount of apache processes:

    Check if your under attack ( Dos Mitigating )

    Also if this is just memory consumption, Log into SSH and type:

    This screen will show all the processes running, Now to view this sorting by the memory press in the screen:

    Show us all the outputs of all commands with the values for a more better response.
     
Loading...

Share This Page