The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Nobody's mail gets forwarded to root e-mail address

Discussion in 'E-mail Discussions' started by ChemicalWH, Feb 1, 2005.

  1. ChemicalWH

    ChemicalWH Active Member

    Joined:
    Mar 4, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    i tried to change it in cpanel "Change System Mail Preferences" but the changes just wont take effect.. no matter what i fill in with "nobody's mail" it keeps forwarding to root

    I'm running
    WHM 9.9.9 cPanel 9.9.9-S15
    Fedora i686 - WHM X v3.1.0

    Is there a way to manually change this? i already tried the localaliases file.. without luck.


    Ruud
     
  2. 3rbhost

    3rbhost Registered

    Joined:
    Oct 23, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    uppppppppppp
     
  3. netlook

    netlook Well-Known Member
    PartnerNOC

    Joined:
    Mar 25, 2004
    Messages:
    335
    Likes Received:
    0
    Trophy Points:
    16
    I'm also interested in :D
     
  4. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    I would like an answer also. I have two servers. The one with my main domain fowards nobody's mail to root, but the second server (without my main domain), actually fowards it to the correct place.
     
  5. clook

    clook Well-Known Member
    PartnerNOC

    Joined:
    Jun 9, 2002
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Preston, UK
    See if /etc/aliases has a line for nobody in there.
     
  6. Mysteerie

    Mysteerie Well-Known Member

    Joined:
    Dec 29, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    It does, and it's under "root".

    Just "root" though, and not an email address?
     
  7. jb605

    jb605 Member

    Joined:
    Dec 5, 2003
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    cpanel mistakenly editing /etc/localaliases instead of /etc/aliases

    I think the problem is that cpanel mistakenly editing /etc/localaliases, while it should really be editing /etc/aliases.

    I have serveral cpanel servers before, never got this problem. Only a very recent server had this error. So the root email setting in "System Mail Preference" in Webhost Manager is now editing the wrong file.

    In your case, just go ahead and edit /etc/aliases and change the line for nobody to whatever email address you want:
    nobody: someemail@somedomain.com

    Then it should be fine.

    Looks like a bug in the new version of cpanel/whm.

    Can anybody else confirm this problem?

    Thanks.
     
  8. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
  9. sawbuck

    sawbuck Well-Known Member

    Joined:
    Jan 18, 2004
    Messages:
    1,367
    Likes Received:
    5
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Nice resource. Thanks David.
     
  10. Cash

    Cash Well-Known Member

    Joined:
    Jun 9, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    I am also facing same problem. How can I solve it?
    I am using WHM 10.0.0 cPanel 10.0.0-C148 & Fedora i686 - WHM X v3.1.0 (Fedora 2)

    When my server came, the "nobody's mail" is forward to abd@domain.com, after I chage it to cde@domain.com, but the nobody mail still delivery to abd@domain.com..... :(
     
  11. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Did you try the link I put in this thread? It is there for a reason...the answer. :D
     
  12. Cash

    Cash Well-Known Member

    Joined:
    Jun 9, 2004
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Just wonder this problem does not happen in my another servers (Redhat enterprise & Fedora core1), only happen to my this fedora core 2 server.. is it the cpanel bug?
     
Loading...

Share This Page