SOLVED Node.js in version 80 with CloudLinux

Ishware

Well-Known Member
Nov 7, 2003
203
6
168
Williamsburg, VA
cPanel Access Level
Root Administrator
From the Version 80 feature showcase, I clicked to provision node.js, and getting this error:

Update Error: The package ea-ruby24-mod_passenger conflicts and we need to install it resolve deps at /usr/local/cpanel/Cpanel/PackMan.pm line 352.

I'm running CloudLinux+CageFS on this box, in case it matters.

Also, once I fix this, I'm not sure how to get back to the feature showcase so I can try to provision all the needed packages - is there a convenient place to get back to that, or a convenient list of all the packages I need to install?

But I'm not sure how to resolve that conflict. I poked around the various parts of EA4 looking for ruby stuff to disable but I don't have any of the ruby stuff enabled as far as I can tell.

Sorry to be a n00b on this — provisioning is still a little mystical and scary for me. heh
 

cPanelMichael

Technical Support Community Manager
Staff member
Apr 11, 2011
47,911
2,234
363
cPanel Access Level
DataCenter Provider
Twitter
Hello @Ishware,

CloudLinux uses their own EasyApache 4 repo and provides separate Node.JS and Mod_Passenger packages. You can read more about these packages at:

Node.js Selector | Documentation

Additionally, CloudLinux documents the following warning:

Most packages from the EA4 cPanel repository are not compatible with CloudLinux packages and this can lead to various errors.
Thank you.