The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Non-Email Account...

Discussion in 'E-mail Discussions' started by GeekPatrolMille, Jan 11, 2005.

  1. GeekPatrolMille

    GeekPatrolMille Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    McKinney, Texas, USA
    The customer has an inhouse mail server (MS Exchange) but I am hosting their Web site and their DNS. All of this works fine as long as the "Verify the existance of email senders" under the "Main >> Service Configuration >> Exim Configuration Editor" is unchecked. If this feature is enabled, they can not send email to any domain which is being hosted on the same server as their web site. The email bounces with the following error...

    Gregory A. Miller on 1/11/2005 1:34 PM
    There was a SMTP communication problem with the recipient's email server. Please contact your system administrator.
    <domain.net #5.5.0 smtp;550-Verification failed for <jmw@domain.net>>

    (domain.net above was modified to prevent spam)

    The exim_log shows the following...

    2005-01-11 21:00:35 H=(domain.net) [206.81.245.136] sender verify fail for <jmw@domain.net>:
    2005-01-11 21:00:35 H=(domain.net) [206.81.245.136] F=<jmw@domain.net> rejected RCPT <gmiller@mailtodomain.com>: Sender verify failed
    2005-01-11 21:00:36 1CoYkO-0002rl-3g H=(domain.net) [206.81.245.136] F=<> rejected after DATA: there is no valid sender in any header line

    Here is the DNS Zone information...

    ; Modified by Web Host Manager
    ; Zone File for lhlaw.net
    $TTL 14400
    @ 14440 IN SOA ns5.agbsm.net. gmiller.mailtodomain.com. (
    2004102719
    28800
    7200
    3600000
    86400
    )

    lhlaw.net. 14400 IN NS ns5.agbsm.net.
    lhlaw.net. 14400 IN NS ns4.agbsm.net.

    lhlaw.net. 14400 IN A 206.81.245.136

    localhost.lhlaw.net. 14400 IN A 127.0.0.1

    lhlaw.net. 14400 IN MX 10 lhlaw.net.

    mail 14400 IN CNAME lhlaw.net.
    www 14400 IN A 65.16.99.55
    ftp 14400 IN A 65.16.99.55
    svr001 14400 IN A 206.81.245.136


    The best I can figure is that Exim is testing against the local machine domain account which has NO email addresses and it just figures the message was forged and rightly rejects it. The question is... Can this be overcome without the obvious answer of turning off the sender verification option...? Can Exim be broken in a way that would affect just this single domain, might be another way to look at it?

    Thanks, any input is appreciated...
    -greg
     
  2. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    remove the domain from /etc/localdomains and put it in /etc/remotedomains
     
  3. GeekPatrolMille

    GeekPatrolMille Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    McKinney, Texas, USA
    Thank You, this worked beautifully...

    -greg
     
Loading...

Share This Page