Non-SSL domains with ports not redirecting to SSL equivalent

cPanel & WHM Version
v100.0.12

TSoarer

Member
Mar 31, 2022
6
2
3
TX
cPanel Access Level
Root Administrator
Having a heck of a time redirecting HTTP://domain:2096 to HTTPS://domain:2096

Just can't seem to redirect any domains with a port. Any help or direction appreciated.

Tweak Settings:

Always redirect to SSL = ON
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,498
1,971
363
cPanel Access Level
Root Administrator
That's odd - that's one of those things that "should just work"

What happens if you set the options to off, origin, origin, no redirection, in the order of those boxes on the page? Does that change the behavior in any way?
 

TSoarer

Member
Mar 31, 2022
6
2
3
TX
cPanel Access Level
Root Administrator
That's odd - that's one of those things that "should just work"

What happens if you set the options to off, origin, origin, no redirection, in the order of those boxes on the page? Does that change the behavior in any way?
Changing to:
OFF
Origin Domain Name
Origin Domain Name
No direction


Did not rectify the issue :/

EDIT: My hosting provider responded back to me, I had a post out to them too, with:
Unfortunately, this will not be possible as the port 2096 is only for SSL and when trying to access it via http will not redirect it to https...
I guess I'll have to ensure that people have the https address...
 
Last edited:

Spirogg

Well-Known Member
Feb 21, 2018
700
161
43
chicago
cPanel Access Level
Root Administrator