The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Normal user can manage any accounts owned by "root"

Discussion in 'General Discussion' started by nino, Mar 22, 2005.

  1. nino

    nino Member

    Joined:
    Mar 21, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I've recently noticed that this warning appears while loging into /cpanel with one of my accounts:

    "Warning: You are logged in using the reseller or root password"

    The option to manage other accounts also appears. In fact, this user can manage any account owned by root.

    I've created this account as a normal user, this is not a reseller and I don't think I gave any other privileges so far. The "good" thing is that this account is for one of my personal websites and I did not notice the same problem in any other account of my customers. If it's not a configuration problem or something that I'm missing to do or did wrong, then it's a really serious Cpanel bug.

    I'm using:
    WHM 9.9.7 cPanel 9.9.8-R5
    RedHat Enterprise 3 i686 - WHM X v3.1.0

    Any Ideas about why this is happening and how to fix it ?

    Thank you,
    Antonio
     
  2. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    It's because the password you gave that account is the same as your root/reseller id's password is. Change the password for that account to something else and it should be fine.
     
  3. nino

    nino Member

    Joined:
    Mar 21, 2005
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I thought that it could be the problem, but I do have another account (not owned by root) with exactly the same password as the root user and the problem does not show up for that one. So, I discarted the possibility ... Anyways, I changed the password and it solved the problem :)

    Thanx for your help.

    Antonio.
     
Loading...

Share This Page