Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

not able to connect remote MySQL : Remote Database Access Hosts

Discussion in 'Database Discussion' started by crazyaboutlinux, Jan 17, 2011.

  1. crazyaboutlinux

    crazyaboutlinux Well-Known Member

    Joined:
    Nov 3, 2007
    Messages:
    939
    Likes Received:
    0
    Trophy Points:
    66
    I am not able to connect remote MySQL

    i have added (% wildcard is allowed, My local Static IP is allowed, Allowed a server IP as well) access the tool via cPanel -> Databases -> Remote MySQL:
    Remote Database Access Hosts

    But still i am getting the same error

    MySQL Query Browser Error Number : 1045

    Could not connect to the speified instance

    MySQL Error Number 1045
    Access Denied for user 'user_nilesh@'xx.xx.209.216' (using password : YES) (comment :xx.xx.209.216 is local ISP)

    if you want to check the network connetion, Please click the Ping Button.
     
  2. garrettp

    garrettp Well-Known Member
    PartnerNOC

    Joined:
    Jun 18, 2004
    Messages:
    312
    Likes Received:
    0
    Trophy Points:
    166
    cPanel Access Level:
    DataCenter Provider
    Have you ruled out the possibility that your credentials are bad by testing them via a localhost connection (e.g. from the server itself)?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. kloring

    kloring Registered

    Joined:
    Aug 19, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    51
    The "@xx.xx.209.216" is the IP you need to create a host for. if u have cable modem its prob dynamic so it will change alot.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,608
    Likes Received:
    32
    Trophy Points:
    238
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Have you ensured that the user has been added to the database in question? Oftentimes, people create the database in cPanel > MySQL Databases area, then create the user there, but do not do the third step to add that MySQL user to the database. That option is toward the bottom of cPanel > MySQL Databases area for the "Add User To Database" section.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Elliot Balanza

    Elliot Balanza Registered

    Joined:
    Oct 5, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    51
    cPanel Access Level:
    Root Administrator
    I'm having the exact same problem, The site is even working via localhost, so yes all is in place, yet i cant connect neither vya MyODBC or to create things with DW.

    The GUI of MySQL works fine so I'm lost here.
     
  6. Igor Volanski

    Igor Volanski Registered

    Joined:
    Apr 3, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    I have the same problem. Everything is tested. Wildcard added, user created, privileges granted, tested username and password from localhost(inside the box) and it is ok. I have no idea about how to solve this problem. Maybe something firewall related.
     
  7. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    45,214
    Likes Received:
    1,936
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Do you have root access to both servers, or are these shared hosting accounts?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice