Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Not all privileges are granted to user when creating mysql database

Discussion in 'Database Discussion' started by ghalman, Feb 27, 2011.

  1. ghalman

    ghalman Member

    Joined:
    Apr 17, 2002
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    301
    Hi,

    Please help. When I my cpnale users create a new database, using wizard or alternate method (and do choose to grant all privileges), the privileges are not correctly assigned.

    when I connect to mysql as root and issue the command SHOW GRANTS; it give me output as below:
    GRANT USAGE ON *.* TO 'cpuser_store'@'localhost' IDENTIFIED BY PASSWORD '23429834205f129b5'

    I tried many times to grant privileges from cPanel, but it never adds them there from the cPanel.

    I had to issue GRANT ALL from the mysql root access for that db and user.

    Anyone know anything why this is happening? This behavior is for all cPanel users. This is relatively new server; and I did upgrade recently.

    I am not sure if this started after upgrade or what!

    Please comment and help here. Thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. huzie

    huzie Member

    Joined:
    Mar 8, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    51
    Hi there,

    I have the same problem.. did you get a resolution?

    thanks
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice