The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

not displaying *.php

Discussion in 'General Discussion' started by Death Barrel, Aug 11, 2006.

  1. Death Barrel

    Death Barrel Registered

    Joined:
    Aug 10, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    hey all,

    sorry i am new to cpanel, hosting company threw it in for free after screwing me over lol... anyways, i've never seen this before and once again i am totally new to cpanel, used to doing things the old fashioned way...

    ok heres what i get>>> when i have a file in the html dir: example> index.html it displays fine... but if i change the extention to *.php it won't display it says >>

    Code:
    Forbidden
    You don't have permission to access /torrent/index.php on this server.
    
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. 
    so i check my apache error log and i see >>>

    Code:
    [Fri Aug 11 23:18:50 2006] [error] [client XX.XX.XX.XX] Options ExecCGI is off in this directory: /usr/local/apache/htdocs/torrent/index.php
    
    now i have tried for the last 2 days to research this problem and one fix said to enable ExecCGI in teh apache conf file.... so i did but that only made it worse....

    any help would be great, it was all working fine before cpanel was added.

    thanks!
    Eric
     
  2. inalto

    inalto Member

    Joined:
    Mar 27, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    seems you have phpsuexec running.
    with phpsuexec php scripts are acting like cgi. Look in your .htaccess, maybe you have Options -ExecCGI.
    If yes remove -ExecCGI from your htaccess.

    You dont Have an htaccess, you can try creating a .htaccess with Options +ExecCGI

    If this does not work maybe is because you have AllowOverride No in the httpd.conf for that dir.

    Also look, you must not have 777 permissions on the php files, 644 is enought.
     
    #2 inalto, Aug 12, 2006
    Last edited: Aug 12, 2006
  3. Death Barrel

    Death Barrel Registered

    Joined:
    Aug 10, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    ok i was able to rebuild apache w/o suEXEC, i got it working now. thanks for your time!
     
Loading...

Share This Page