Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Not getting logwatch email

Discussion in 'E-mail Discussion' started by gundamz, Mar 19, 2007.

  1. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    316
    Hi,



    I see that 0logwatch is in /etc/cron.daily . However, i have not being getting logwatch email for a month. I have double check that the root email is set to mine. My email account is working as well.

    I am running centOS 4.4

    What could be wrong?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    If you have enabled extended exim logging to include adding the Subject to exim transactions, then try searching the exim_mainlog to get the mail transactions for the logwatch email:

    grep -i logwatch /var/log/exim_mainlog

    Then grep the same log for the transation ID, e.g.:

    grep 1HT94R-0003YH-V2 /var/log/exim_mainlog

    If you haven't enabled extended exim logging, then add the following to the first textarea in the Advanced mode Exim Configuration Editor in WHM:

    log_selector = +subject +arguments

    Then check it the next time logwatch runs.

    Also, as the logwatch cron runs as part of the daily crontab, make sure that MAILTO=root is set in /etc/crontab
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    655
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Canada
    Check your /etc/log.d/conf/logwatch.conf

    Search for: MailTo

    It should be
    MailTo = root

    Make sure your have /root/.forward and it has a current email address in it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. gundamz

    gundamz Well-Known Member

    Joined:
    Mar 27, 2002
    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    316
    In my /root/.forward, it is "root" .
    LOL.
    now, i know why i am not getting emails..
    i am sending to nowhere..
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #4 gundamz, Mar 19, 2007
    Last edited: Mar 19, 2007
  5. ramprage

    ramprage Well-Known Member

    Joined:
    Jul 21, 2002
    Messages:
    655
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Canada
    glad you found the reason :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice