The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not getting system/root mail?

Discussion in 'General Discussion' started by mbressman, Nov 17, 2014.

  1. mbressman

    mbressman Active Member

    Joined:
    Jan 31, 2006
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    When I first had my VPS set up, I was getting nightly emails, such as from upcp, anacron, etc. However, in the past month I've completely stopped getting them. I can see from /var/cpanel/updatelogs that the upcp cron job still seems to be running, and yet I'm not getting the nightly output email. I am pretty sure I have everything configured correctly on my end (although I'm attaching screenshots of what I'm guessing are the applicable sections of WHM), but am concerned about why these emails stopped. Any help is greatly appreciated. Thanks!
     

    Attached Files:

  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    650
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Do you notice any output in /var/log/exim_mainlog for the root contact? EX:

    Code:
    exigrep user@domain /var/log/exim_mainlog
    Thank you.
     
  3. mbressman

    mbressman Active Member

    Joined:
    Jan 31, 2006
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    I'm guessing you didn't want me to actually use "user@domain", right? But wasn't sure what to put in there as a search string instead. I tried just using "root" (without quotations) and got a ton of output, but most recent looks like this:

    Code:
    +++ 1XqCac-0001hu-Q6 has not completed +++
    2014-11-16 22:02:54 1XqCac-0001hu-Q6 <= <> R=1XqCab-0001hm-O7 U=mailnull P=local S=1547 T="Mail delivery failed: returning message to sender" for root@<DOMAIN>.com
    2014-11-16 22:02:56 1XqCac-0001hu-Q6 ** root@<DOMAIN>.com R=dkim_lookuphost T=dkim_remote_smtp X=TLSv1.2:DHE-RSA-AES256-GCM-SHA384:256: SMTP error from remote mail server after MAIL FROM:<> SIZE=2607: host <DOMAIN>.com [173.236.66.164]: 550 "REJECTED - Bad HELO - Host impersonating [<DOMAIN>.com]"
    2014-11-16 22:02:56 1XqCac-0001hu-Q6 Frozen (delivery error message)
    2014-11-16 22:29:05 1XqCac-0001hu-Q6 Message is frozen
    2014-11-16 23:29:05 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 00:29:05 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 01:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 02:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 03:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 04:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 05:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 06:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 07:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 08:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 09:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 10:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 11:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 12:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 13:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 14:29:08 1XqCac-0001hu-Q6 Message is frozen
    2014-11-17 15:29:08 1XqCac-0001hu-Q6 Message is frozen
    
    
    I just replaced the actual domains in the above code with <DOMAIN>

    Could this be because the VPS is configured to use one domain, but I haven't actually attached that domain to the VPS yet??

    Thanks!
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    650
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Instead of "root", search for the email address that you have configured as the "root" contact address in "WHM Home » Server Contacts » Edit System Mail Preferences".

    Thank you.
     
  5. mbressman

    mbressman Active Member

    Joined:
    Jan 31, 2006
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Just tried - the stuff that I see when I use my configured email address are emails that are actually making it to me, such as:

    SSH root login (which is configured in my shell I believe)
    CHKROOTKIT nightly scan result emails
    Softaculous software update emails

    I don't see anything relating to the upcp emails or anything else out of the ordinary?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    650
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page