Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Not receiving emails from WHM anymore

Discussion in 'E-mail Discussion' started by DreamPhysix, Jul 25, 2012.

  1. DreamPhysix

    DreamPhysix Well-Known Member

    Joined:
    Sep 30, 2009
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    56
    Typically I wake up in the morning with an email about cron upcp running overnight. This morning I didn't get an email and my server was not offline. I went into WHM (which typically sends me emails on login but doesn't do that either) and there was nothing in the mail queue. I haven't changed any settings in my email or WHM. Is there some log I can look at to see what happened to these emails? I'm concerned that I won't get emails anymore from cphulkd which is important to me
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,309
    Likes Received:
    393
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You might have some luck looking here:
    WHM > Email > Mail Delivery Reports

    Set date and time of day you normally get the logs and then "Run Report"

    On Actions column on right, you'll see a small magnifying glass, click that for more details of the items you find.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DreamPhysix

    DreamPhysix Well-Known Member

    Joined:
    Sep 30, 2009
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    56
    It shows emails that were sent by users, but no emails sent by WHM to me appear during the time frame :(

    Edit: It appears that my contact manager in WHM had emails disabled for cphulk even though it was enabled in cphulk. Still no email about root logins though. As for the email from cron upcp, still not sure
     
    #3 DreamPhysix, Jul 25, 2012
    Last edited: Jul 25, 2012
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    16,309
    Likes Received:
    393
    Trophy Points:
    583
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Here:
    WHM > Server Contacts > Contact Manager

    I have Email at top, set to Low.

    Below in Alert Priority Assignment I have all of these selected and on Low as well.

    All those alert emails are sent according to this setting:
    WHM > Server Contacts > Change System Mail Preferences, root's mail

    Even if you had a bad email in there for root, the system would still be generating the emails though even if they couldn't be sent, or bounced.

    Assuming you've got a default EXIM setup you might try going to:
    WHM > Service Configuration > Exim Configuration Manager, scroll to bottom and click Save.

    Not sure how helpful that might be but couldn't hurt.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. DreamPhysix

    DreamPhysix Well-Known Member

    Joined:
    Sep 30, 2009
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    56
    Exim restarted fine and system mail preferences look okay. I'll restart the entire server and see what happens. *fingers crossed*

    Edit: When I restarted my server, the following appeared in my console after the login prompt:

    I also received an email (which is a good start) with the following:

    Edit: I logged into WHM with a non-whitelisted IP and I got the expected email notification. Hopefully things are fixed now
     
    #5 DreamPhysix, Jul 25, 2012
    Last edited: Jul 25, 2012
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice