The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not receiving mails from comcast.. (550 callback..)

Discussion in 'E-mail Discussions' started by ramystyle, Mar 28, 2007.

  1. ramystyle

    ramystyle Well-Known Member

    Joined:
    Feb 9, 2004
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Montreal
    For some reason... No one with a Comcast.net email address can email us..

    Always the Rejected Email comes back with This message:

    ==============================================================
    A message (from <yyyyyyy@comcast.net>) was received at 29 Mar 2007 3:15:15 +0000.

    The following addresses had delivery problems:

    <yyyyy@sellwebhost.com>
    Permanent Failure: 550-Callback_setup_failed_while_verifying_<yyyyyyy@comcast.net>
    Delivery last attempted at Thu, 29 Mar 2007 03:15:18 -0000
    =============================================================


    I have used "yyyyyyy" only to alter the email address for privacy..

    Any idea why ?

    Thanks
     
  2. m82492

    m82492 Member

    Joined:
    Mar 30, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Same problem here. I set up my email accounts in Cpanel and tried to send test emails from my Comcast email address. Bounces back to me on both ends. I thought I set up the email wrong. I'll have to try with my Yahoo account. Anyone else have this issue or is this something we are doing wrong?
     
  3. phil-3

    phil-3 Member

    Joined:
    Mar 29, 2007
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Have you tried disabling callbacks on you server.

    Callbacks are abusive anyway and should never be used.:D

    All the best

    Phil
     
  4. SageBrian

    SageBrian Well-Known Member

    Joined:
    Jun 1, 2002
    Messages:
    415
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    NY/CT (US)
    cPanel Access Level:
    Root Administrator
    I disagree. They can be abusive, if a spammer is abusing the system.
    But, all the callbacks are doing is checking with the 'senders' server to see if we can send a bounce back to them, if there is an error.

    If it's a valid address, and a valid email, there is no problem. A server should accept a callback.

    The problem comes from the spammers using someone else's address. Yes, that becomes an issue. But who is at fault, and doing the abusing? Not the receiving server who is simply trying to check if it's a valid email.

    So, should the receiving server take the abuse in the form of spam (utilizing resources to then run filters on all of the invalid mail), or should callbacks be used to send a quick query to test validity?

    1000 spam emails, using comcast.net as a false sender.
    Receiving server says hello, checks the return address and checks with comcast to see if it's a valid address. Receiving server had to deal with 1000 delivery attempts. Comcast had to deal with 1000 callback checks. If not valid, mail not accepted. No extra resources used.
    If the address is validated by comcast, they are out of the loop. The receiving server nows has to process/filter/delivery the 1000 emails.

    The big picture is that callback is a way to lessen overall resources by simply not accepting mail. By comcast saying 'we don't want to answer your callbacks', they are saying 'we expect all other servers to process all mail regardless of valid senders so we don't have use the smaller process of simply checking'.

    No solution is perfect.
     
  5. m82492

    m82492 Member

    Joined:
    Mar 30, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ok so what's the solution? How do I make it so I can send email to my account and from my account with Comcast? I have a comcast account so it would be nice to be able to send to and fro without getting the errors.
     
  6. phil-3

    phil-3 Member

    Joined:
    Mar 29, 2007
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Yes the receiving server IS at fault. Callbacks are a bad thing. They are used and abused in DDOS attacks on email servers (even if unintentionally)

    How can you be happy about knowingly participating in an attack on someone elses server ?

    Look at this scenario (and it is painfully common and growing day by day). A botnet sends out a million emails using a forged address on one of your servers. Lets suppose that only 5% of the receiving servers used callback. That's FIFTY THOUSAND callbacks that you are going to get. And it's not just the number of them - it's the bandwidth that YOU have to pay for that is being used, plus the entire servers downtime.

    You are right there is no perfect solution, but Callback (and other related Challenge Response type systems) ARE abusive and only make the whole spam problem worse.

    All the best

    Phil
     
  7. m82492

    m82492 Member

    Joined:
    Mar 30, 2007
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Let me see if I have this straight...I can't send anything to my Cpanel email because callbacks are enabled (somehow) on my Cpanel email address and Comcast doesn't like the callbacks? Is that the problem? Will someone please let me know what I need to do to make comcast email addresses able to email my Cpanel email. I just need to know how to make it work.

    Thanks
     
  8. Vinayak

    Vinayak Well-Known Member

    Joined:
    Jun 27, 2003
    Messages:
    267
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Bharat
    cPanel Access Level:
    Root Administrator
    I am not sure but this could be one of the reason, if you have callback enabled there may be nothing wrong in that mechanism, but then you have to look into the acl if you are using this entrysome where:

    relays.ordb.org

    I had the similar problem for months, never got the answer, but then somewhere I read that culprit is relays.ordb.org

    On my server this entry is at

    Service Configuration->Exim Configuration Editor

    Then click on Advanced Editor

    Look into Second of the first Three Boxes:

    Code:
    # The following is a list of RBL to check for spam.
    dnslists = list.dsbl.org : \
    sbl.spamhaus.org : \
    relays.ordb.org
    delay = 3s
    Convert it to:
    Code:
    # The following is a list of RBL to check for spam.
    dnslists = list.dsbl.org : \
    sbl.spamhaus.org
    # relays.ordb.org
    delay = 3s

    Save and restart Exim. Check the result.

    Hopefully the problem will be solved.
     
Loading...

Share This Page