The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not showing dedicated website IP

Discussion in 'General Discussion' started by Jaffery, Sep 19, 2016.

  1. Jaffery

    Jaffery Member

    Joined:
    Mar 15, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I have a domain with dedicated IP assigned to it. However there is an issue when I make request from this domain account to another third party service, it is showing main server IP in $_SERVER[REMOTE_ADDR] instead of website's dedicated IP. However, the remote third party service I need to access from this domain requires us to have this domain's dedicated IP only.

    Kindly advice..
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,738
    Likes Received:
    661
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    It's normal for outgoing connections to come from the default public IP address of the server. Assigning an account a dedicated IP address will not change this behavior. Are you able to modify your application settings so it expects connections from the main IP address of the server? If not, you may need to consult with a qualified system administrator to see if any custom network configurations are possible for the behavior you are seeking.

    Thank you.
     
Loading...

Share This Page