The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not sure whahe problem is but.....

Discussion in 'General Discussion' started by servertrouble, Feb 2, 2006.

  1. servertrouble

    servertrouble Registered

    Joined:
    Feb 2, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to setup my own nameservers in cpanel but when I restart bind in WHM I get this:

    named started ok Feb 2 13:08:35 secure named[779]: stopping
    command channel on 127.0.0.1#953 Feb 2 13:08:35 secure
    named[779]: exiting Feb 2 13:08:35 secure named[1229]: starting
    BIND 9.3.1 -u bind -c /etc/namedb/named.conf -t /var/named Feb 2
    13:08:35 secure named[1229]: command channel listening on
    127.0.0.1#953 Feb 2 13:08:35 secure named[1229]:
    dns_rdata_fromtext: /etc/namedb/localhost.rev:10: near
    '@host@.': bad name (check-names) Feb 2 13:08:35 secure
    named[1229]: zone 0.0.127.IN-ADDR.ARPA/IN: loading master file
    /etc/namedb/localhost.rev: bad name (check-names) Feb 2 13:08:35
    secure named[1229]: dns_rdata_fromtext:
    /etc/namedb/localhost-v6.rev:10: near '@host@.': bad name
    (check-names) Feb 2 13:08:35 secure named[1229]: zone
    1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA/IN:
    loading master file /etc/namedb/localhost-v6.rev: bad name
    (check-names) Feb 2 13:08:35 secure named[1229]:
    dns_rdata_fromtext: /etc/namedb/localhost-v6.rev:10: near
    '@host@.': bad name (check-names) Feb 2 13:08:35 secure
    named[1229]: zone
    1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.INT/IN:
    loading master file /etc/namedb/localhost-v6.rev: bad name
    (check-names) Feb 2 13:08:35 secure named[1229]: running


    I know it says running it also says bad name
    (check-names)

    please can anyone tell me what might be causing this and causeing my name server noto work thanks guys

    by the way I am running freebsd 5.4
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    You need to open the file with the error and correct the directives there. There is nothing much to it, assuming other DNS zones and related files are configured properly.
     
  3. mitgib

    mitgib Well-Known Member
    PartnerNOC

    Joined:
    Apr 9, 2006
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    I have a similar error, I've corrected the zone files to clear the error, which was invalid number, but not sure why when transfer a site between servers I am getting it, I looked at the zone templates, and all are like this

    But the error, when I looked at the zone files of the bad ones looked like this:

    Is there someplace other than the 3 template files creating zone files I am overlooking?

    just for full details:

    WHM 11.1.0 cPanel 11.4.6-R13580
    FEDORA 6 i686 - WHM X v3.1.0
     
Loading...

Share This Page