Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED Not using downloaded cpanel-plugins/repomd.xml

Discussion in 'General Discussion' started by Dezdan, Jan 5, 2018.

  1. Dezdan

    Dezdan Member

    Joined:
    Jan 28, 2013
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    After a recent reboot, every few hours I am now receiving an email from my Cron Daemon with the following information:

    /etc/cron.hourly/0yum-hourly.
    cron:
    Not using downloaded cpanel-plugins/repomd.xml because it is older than what we have:
    Current : Wed Jan 3 07:02:02 2018
    Downloaded: Mon Nov 13 11:56:52 2017

    I've run a software update, to no avail. Suggestions on how to fix this issue?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,802
    Likes Received:
    1,714
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Can you let us know the contents of the /etc/cron.hourly/0yum-hourly file? EX:

    Code:
    cat /etc/cron.hourly/0yum-hourly
    Ensure to replace any identifying information about the server with examples.

    Thank you.
     
  3. Lee Young

    Lee Young Registered

    Joined:
    Dec 19, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Troon
    cPanel Access Level:
    Root Administrator
    Getting the exact same error on my server with slightly different times.

    /etc/cron.hourly/0yum-hourly.cron:

    Not using downloaded cpanel-plugins/repomd.xml because it is older than what we have:
    Current : Wed Jan 3 15:02:02 2018
    Downloaded: Mon Nov 13 19:56:52 2017
     
  4. Dezdan

    Dezdan Member

    Joined:
    Jan 28, 2013
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Looks like it doesn't exist.
    Code:
    [root@host ~]# cat /etc/cron.hourly/0yum-hourly
    cat: /etc/cron.hourly/0yum-hourly: No such file or directory
     
  5. Lee Young

    Lee Young Registered

    Joined:
    Dec 19, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Troon
    cPanel Access Level:
    Root Administrator
    same , get No such file or directory
     
  6. Lee Young

    Lee Young Registered

    Joined:
    Dec 19, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Troon
    cPanel Access Level:
    Root Administrator
    missed out the .cron extension in the cat command.

    contents below :

    #!/bin/bash

    # Only run if this flag is set. The flag is created by the yum-cron init
    # script when the service is started -- this allows one to use chkconfig and
    # the standard "service stop|start" commands to enable or disable yum-cron.
    if [[ ! -f /var/lock/subsys/yum-cron ]]; then
    exit 0
    fi

    # Action!
    exec /usr/sbin/yum-cron /etc/yum/yum-cron-hourly.conf
     
  7. cPWilliamL

    cPWilliamL cP Technical Analyst II
    Staff Member

    Joined:
    May 15, 2017
    Messages:
    257
    Likes Received:
    29
    Trophy Points:
    103
    Location:
    America
    cPanel Access Level:
    Root Administrator
    Hi,

    Thank you for your reports @Lee Young and @Dezdan. This is an issue with the update server mirrors being out of sync. You may safely ignore the email alert for now. The sysadmin team has already been made aware of this issue. I'll update this post once our sysadmin team reports it has been resolved.

    Edit: Our sysadmin team is already reviewing the issue
    Edit1: Issue identified, fix still underway
    Edit2: All mirrors should be corrected at this time; you may see some residual emails/alerts though. You may want to issue `yum clean all' or a `yum makecache' to force the update; however, it should be corrected by itself. If you continue to face issues, please update this thread or open a ticket.

    Thanks,
     
    #7 cPWilliamL, Jan 7, 2018
    Last edited: Jan 7, 2018
    Infopro likes this.
Loading...

Share This Page