NOTE: Filesystem quotas are enabled

Nirjonadda

Well-Known Member
May 8, 2013
724
27
78
cPanel Access Level
Root Administrator
I want enable Backup Configuration feature but I am getting one Note from Configure Backup Directory. Please let me know that How we can do the Backup configuration? Also How we can setup backup only in Google Drive, not local directory or local hard drive?

Screenshot_96.png
 

SysSachin

Well-Known Member
Aug 23, 2015
604
48
28
India
cPanel Access Level
Root Administrator
Twitter

Nirjonadda

Well-Known Member
May 8, 2013
724
27
78
cPanel Access Level
Root Administrator

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello,

Click on "Edit" for the Google Drive backup destination, and ensure to enable the following option if you want system backups stored on the remote destination:

Transfer System Backups to Destination

Thank you.
 

Nirjonadda

Well-Known Member
May 8, 2013
724
27
78
cPanel Access Level
Root Administrator
Hello,

Click on "Edit" for the Google Drive backup destination, and ensure to enable the following option if you want system backups stored on the remote destination:

Transfer System Backups to Destination

Thank you.

No need Enable Backup Status from Backup Configuration? But why showing Note, Is this any error from server?

Code:
NOTE: Filesystem quotas are enabled. To prevent performance degradation, the system automatically disables quotas on non-root filesystems that contain a backup destination.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
NOTE: Filesystem quotas are enabled. To prevent performance degradation, the system automatically disables quotas on non-root filesystems that contain a backup destination.
You can safely ignore that warning message since you are not storing backups locally. The "/backup" directory is on the root filesystem in the example you provided, meaning that quotas are not automatically disabled. This would apply if you were using /home as the local backup directory, and /home was on it's own separate partition.

Thank you.
 

Nirjonadda

Well-Known Member
May 8, 2013
724
27
78
cPanel Access Level
Root Administrator
You can safely ignore that warning message since you are not storing backups locally. The "/backup" directory is on the root filesystem in the example you provided, meaning that quotas are not automatically disabled. This would apply if you were using /home as the local backup directory, and /home was on it's own separate partition.

Thank you.
So we can not storing backups locally in "/backup" directory ? Does not have option Scheduling and Retention in Google Drive backup destination? Its Backup Daily or Backup Weekly?
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
So we can not storing backups locally in "/backup" directory ?
You can, but it's not recommended if you don't have a separate partition for the /home directory.

Does not have option Scheduling and Retention in Google Drive backup destination? Its Backup Daily or Backup Weekly?
There's no option to have separate retention periods for each destination. There's a feature request open for this functionality at:

Ability to control retention for S3 Backup Destination

It mentions "Amazon S3" in the title, but the request would apply to any remote destination.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
So Its Backup Daily or Backup Weekly? I have not any backup files in Google Drive after 5 day.
The retention settings you configure apply to all backup destinations (both local and remote). As far as the lack of backups on your remote destination, do you notice any error messages in your backup logs located in the /usr/local/cpanel/logs/cpbackup/ directory?

Thank you.
 

Nirjonadda

Well-Known Member
May 8, 2013
724
27
78
cPanel Access Level
Root Administrator
The retention settings you configure apply to all backup destinations (both local and remote). As far as the lack of backups on your remote destination, do you notice any error messages in your backup logs located in the /usr/local/cpanel/logs/cpbackup/ directory?

Thank you.
Does not have any /usr/local/cpanel/logs/cpbackup/ directory. I have not Enabled local backup.

Screenshot_101.png
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Does not have any /usr/local/cpanel/logs/cpbackup/ directory. I have not Enabled local backup.
That option is for backups in general, and is not specific to local backups. You'd need to enable that option and then uncheck "Retain backups in the default backup directory." if you want to disable local backups.

Thank you.
 

Nirjonadda

Well-Known Member
May 8, 2013
724
27
78
cPanel Access Level
Root Administrator
That option is for backups in general, and is not specific to local backups. You'd need to enable that option and then uncheck "Retain backups in the default backup directory." if you want to disable local backups.

Thank you.
I have uncheckd "Retain backups in the default backup directory" Then does system automatically disables quotas on non-root filesystems that contain a backup destination? But still showing NOTE: Filesystem quotas are enabled. The "/backup" directory meaning that quotas are not automatically disabled?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363
Hello,

The warning message will appear no matter what. Quotas will not be disabled based on the information you have provided because you have a separate partition for /home.

Thank you.
 

Nirjonadda

Well-Known Member
May 8, 2013
724
27
78
cPanel Access Level
Root Administrator
Hello,

The warning message will appear no matter what. Quotas will not be disabled based on the information you have provided because you have a separate partition for /home.

Thank you.

One more question, In case If automatically disables quotas then how we can re-enable quotas? Also How to check if quotas enabled or not? If quotas disabled then does happen any problem?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,203
363