NS not working properly in home server

azadhussnain

Well-Known Member
May 28, 2020
62
0
6
India
cPanel Access Level
Root Administrator
Hello everyone, i have setup a home server with dedicated line for internet and leased ips. i have installed centos 7 and installed cpanel on it. The server is working fine, i have tried to ping google.com , 8.8.8.8 and a few domains they're pinging correctly. I am able to open cPanel WHM. Everything is working properly but i am facing a few issues. I have created Hostnames in GoDaddy for my domain, my domain is connected to CloudFlare so i also added A records there and pointed my A records to the server IP. The records were pointing fine i have checked with many dns checker websites. Just the issue is when i set those nameservers in any domain then that domain doesn't points to any Ip address. The A record which i created were working fine, they're poiting to the IP address. I have connected another domain to cloudflare and pointed that domain's A record to server ip and that domain is pointing and working properly.

but the domain in which i have setup nameservers doesn't work, it doesn't points to any ip address even nameservers were pointing to the correct ip address. i tried pinging the nameservers and they resolves to correct ip address.

anyone can help me out?
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
11,032
1,741
363
cPanel Access Level
Root Administrator
Hey there! I'm wondering if your local network has the correct ports open that are required for the nameserver service to function. From a remote server on a different network, can you run this test?

Code:
nmap -sU your.nameserver.com -p 53
That will test to see if UDP packets over port 53 can be accepted on your network. For example, here is the output when querying the cPanel nameservers:

Code:
# nmap -sU c.cpanel.net -p 53
Starting Nmap 7.70 ( https://nmap.org ) at 2022-06-13 13:08 EDT
sendto in send_ip_packet_sd: sendto(4, packet, 40, 0, 208.74.121.52, 16) => Operation not permitted
Host is up (0.044s latency).

PORT   STATE SERVICE
53/udp open  domain

Nmap done: 1 IP address (1 host up) scanned in 0.71 seconds
which are the expected results.