numerous /opt/cpanel/ea-php56/root/usr/bin/php-cgi

Alan Lehman

Registered
Aug 31, 2018
1
0
1
USA
cPanel Access Level
Root Administrator
My VPS server has started producing numerous /opt/cpanel/ea-php56/root/usr/bin/php-cgi processes pointing to index.php on my httpd server root. Eventually the server overloads and hangs with hundreds of these apparently stuck processes running. If I stop httpd, they stop accumulating and I can kill them.

Can someone help me identify the cause.

Thank you,
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,262
313
Houston
Aug 27, 2019
2
0
1
United states
cPanel Access Level
Website Owner

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,262
313
Houston
What does this mean if the site is set to 7.2 but still getting this process and this issue?
You're saying that you're getting this error specifically but none of the sites are running php 5.6? It would indicate you have a site running PHP 5.6, this process won't run without that version of PHP being used.
 
Aug 27, 2019
2
0
1
United states
cPanel Access Level
Website Owner
You're saying that you're getting this error specifically but none of the sites are running php 5.6? It would indicate you have a site running PHP 5.6, this process won't run without that version of PHP being used.
Thanks for responding. What I'm seeing is multiple sites on the server within WHM. The Owner account for a specific site is showing /opt/cpanel/ea-php56/root/usr/bin/php-cgi as a process in the "Process Manager" in WHM. We currently put up a POST block on the site in htaccess file and it prevents this from happening but it seems to be as mentioned in the previous post where it creates a large number of processes eventually taking the whole server down.

Edit: I forgot to mention this site is on PHP 7.2 in Cpanel there may be a few sites on the server set to either 7.2 or 5.6 but it seems to be showing this for the site that is set to 7.2.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,262
313
Houston
I'm not sure this is still a relevant issue in relation to this thread but can you please open a ticket using the link in my signature? Once open please reply with the Ticket ID here so that we can update this thread with the resolution once the ticket is resolved.


Thanks!
 

Bestsupersite

Member
Jan 19, 2017
12
3
3
Macedonia
cPanel Access Level
Root Administrator
Thanks for responding. What I'm seeing is multiple sites on the server within WHM. The Owner account for a specific site is showing /opt/cpanel/ea-php56/root/usr/bin/php-cgi as a process in the "Process Manager" in WHM. We currently put up a POST block on the site in htaccess file and it prevents this from happening but it seems to be as mentioned in the previous post where it creates a large number of processes eventually taking the whole server down.

Edit: I forgot to mention this site is on PHP 7.2 in Cpanel there may be a few sites on the server set to either 7.2 or 5.6 but it seems to be showing this for the site that is set to 7.2.
Did you fixed the issue?