Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

OAuth PHP Extension not working

Discussion in 'General Discussion' started by blipper, Aug 5, 2017.

  1. blipper

    blipper Member

    Joined:
    Jan 27, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    51
    I need to install a component in Joomla and am getting this error:
    Error
    Oauth Extension is not enabled in your server.

    So I went to WHM --> Module Installers --> “PHP Extensions and Applications Package” Installer
    I found Oauth, clicked install and it now appears in my installed PHP extensions. But for all intents and purpose, I'm still getting an error that it's not enabled, nor does it show up in my phpinfo page.

    What am I missing to get this installed?
    php 5.6.31
    Centos 6.9
    cpanel 64, build 35.

    Ideas?
     
  2. 24x7server

    24x7server Well-Known Member

    Joined:
    Apr 17, 2013
    Messages:
    1,484
    Likes Received:
    60
    Trophy Points:
    28
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    What do you see when you execute below command:
    # php -m | grep -i "OAuth"
     
  3. blipper

    blipper Member

    Joined:
    Jan 27, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    51
    Hi there, when I run that command, there are no results.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Did you install this PECL module for the version of PHP utilized by the website? Does this account use any custom php.ini files?

    Thank you.
     
  5. blipper

    blipper Member

    Joined:
    Jan 27, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    51
    Hi, this account does not have a custom php. And on the particular website, when I install it, I get this:

    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/oauth.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20131226/oauth.so: cannot open shared object file: No such file or directory in Unknown on line 0 uninstall ok: channel://pear.php.net/HTTP_OAuth-0.3.2 PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20131226/oauth.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20131226/oauth.so: cannot open shared object file: No such file or directory in Unknown on line 0 pear/HTTP_OAuth can optionally use PHP extension "pecl_http" (version >= 1.6.0) downloading HTTP_OAuth-0.3.2.tgz ... Starting to download HTTP_OAuth-0.3.2.tgz (56,461 bytes) ..............done: 56,461 bytes install ok: channel://pear.php.net/HTTP_OAuth-0.3.2

    And sure enough, if I go to /usr/local/lib/php/extensions/no-debug-non-zts-20131226/, I do not see oauth.so there.

    Any ideas?
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,425
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Feel free to open a support ticket using the link in my signature so we can take a closer look at your system.

    Thank you.
     
Loading...

Share This Page