Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED OCI8 requires PHP 7

Discussion in 'EasyApache' started by anna lopez, Jul 3, 2018.

  1. anna lopez

    anna lopez Member

    Joined:
    Jul 3, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toluca
    cPanel Access Level:
    Root Administrator
    I have this issue:
    pecl/oci8 requires PHP (version >= 7.0.0), installed version is 5.6.36
    No valid packages found

    Anyone know what can i do
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,724
    Likes Received:
    74
    Trophy Points:
    203
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    install php 7 with easyapache
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. anna lopez

    anna lopez Member

    Joined:
    Jul 3, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toluca
    cPanel Access Level:
    Root Administrator
    Thanks but not the solution i'm looking for
     
  4. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,721
    Likes Received:
    186
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Hi @anna lopez

    the extension is only available for PHP 7 or greater so in order to utilize it you'll need to install php 7 or higher as indicated by the message.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. anna lopez

    anna lopez Member

    Joined:
    Jul 3, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Toluca
    cPanel Access Level:
    Root Administrator
    Thanks, I found the solution:
    * Install packages instantclient12.1-basic y instantclient12.1-devel
    * Install oci8-2.0.12 with pecl.
    * Edit php.ini
    * Restart apache

    Thanks
     
  6. cPanelLauren

    cPanelLauren Forums Analyst
    Staff Member

    Joined:
    Nov 14, 2017
    Messages:
    2,721
    Likes Received:
    186
    Trophy Points:
    143
    Location:
    Houston
    cPanel Access Level:
    DataCenter Provider
    Thanks for updating with the solution that worked for you it should be noted that through WHM>>Software>>Module Installers we only offer v2.1.8 so in order to use the version you wanted you needed to install the module outside of the Module Installers interface.

    Thanks!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice