Odd -empty /usr/local/lib/php/extensions/no-debug-non-zts-20090626/

pixert

Member
Feb 13, 2011
8
0
51
I get this warning in my error_log :
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/: cannot open shared object file: No such file or directory in Unknown on line 0
My error_log would go up with this error

I check /usr/local/lib/php/extensions/no-debug-non-zts-20090626/. It's empty no extension there.
I googled this problem, the best suggestion I got that to copy those extensions to above folder and add it to dynamic library section in php.ini

I've been looking all php extension I've installed, but don't know where to look at.

Please help where can I find those extensions or .so? I'm using easy apache with PHP 5.3.4
Thanks
 
Last edited:

pixert

Member
Feb 13, 2011
8
0
51
I'm using Ion Cube. I downgraded the PHP to 5.2.16. The error still exists.
Apache version is 2.2. Do I have to downgrade the Apache?
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Can you please try the following commands in root SSH:

Code:
/scripts/phpextensionmgr uninstall IonCubeLoader
/scripts/phpextensionmgr install IonCubeLoader
You shouldn't have to re-run Apache nor downgrade it to get IonCube working. We provide the script above to uninstall and install IonCubeLoader and several other PHP extensions. You can run the following command to see which are available to uninstall and/or install using that script:

Code:
/scripts/phpextensionmgr list
 

pixert

Member
Feb 13, 2011
8
0
51
Thank you, Tristan.
You really helpful. I have a question about php.ini
i don't see extension=mcrypt.so in php ini.
I installed mcrypt via exhaustive options list, but i can't see mycrypt.so in /usr/local/lib/php/extensions/no-debug-non-zts-20060613/ (I downgraded the PHP). I'm also using suphp.

Odd. Error_log fires up below warning everytime i'm executing php files
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/: cannot open shared object file: No such file or directory in Unknown on line 0

Any suggestion?
 

ModServ

Well-Known Member
Oct 17, 2006
337
5
168
Egypt
cPanel Access Level
Root Administrator
i don't see extension=mcrypt.so in php ini.
I installed mcrypt via exhaustive options list, but i can't see mycrypt.so in /usr/local/lib/php/extensions/no-debug-non-zts-20060613/ (I downgraded the PHP). I'm also using suphp.
You can execute this command to know the modules in PHP

Code:
php -m
And to make sure the module is installed just do this

Code:
php -m | grep mcrypt
If it appears then it's installed.


Odd. Error_log fires up below warning everytime i'm executing php files
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/: cannot open shared object file: No such file or directory in Unknown on line 0
Get the right path of the extensions then change it in your php.ini to make this error not appear again.
 
Last edited:

pixert

Member
Feb 13, 2011
8
0
51
Hi Me_388, thank you so much for your help.
How can I find the right path of the module?
 

ModServ

Well-Known Member
Oct 17, 2006
337
5
168
Egypt
cPanel Access Level
Root Administrator
Hello pixert,

You welcome...

About the extensions you mean on the second problem you could execute this command

Code:
ls -lh /usr/local/lib/php/extensions/no-debug-non-zts*
Then you could take the right path with right numbers
Code:
no-debug-non-zts-xxxxxxxx
and change it in your php.ini file. Then don't forget to restart apaceh

Code:
service httpd restart
 

pixert

Member
Feb 13, 2011
8
0
51
there's no another file in /usr/local/lib/php/extensions/no-debug-non-zts*.
that's odd. php.ini says the correct path, but no .so* file there? easy apache installed the correct modules
I did try easy apache via WHM and SSH, same results
 
Last edited:

ModServ

Well-Known Member
Oct 17, 2006
337
5
168
Egypt
cPanel Access Level
Root Administrator
Hello,

Really, That's weird, Here are my result:

Code:
[email protected] [~]# ls -lh /usr/local/lib/php/extensions/no-debug-non-zts*
total 4.4M
drwxr-xr-x 2 root root 4.0K Jan 24 01:33 ./
drwxr-xr-x 3 root root 4.0K Oct  8 10:46 ../
-rwxr-xr-x 1 root root 413K Jan 19 07:52 eaccelerator.so*
-rwxr-xr-x 1 root root 134K Dec  4 02:01 pdo_mysql.so*
-rwxr-xr-x 1 root root 298K Dec  4 02:01 pdo.so*
-rwxr-xr-x 1 root root 1.7M Dec  4 02:01 pdo_sqlite.so*
-rwxr-xr-x 1 root root 1.3M Dec  4 02:01 sqlite.so*
-rwxr-xr-x 1 root root 608K Jan 19 07:52 suhosin.so*
-rwxr-xr-x 1 root root  49K Jan 23 19:06 uploadprogress.so*
 

ModServ

Well-Known Member
Oct 17, 2006
337
5
168
Egypt
cPanel Access Level
Root Administrator
Could you try to execute those two commands:

Code:
updatedb
Note: It will take a lot of time depending on your server spec and number of files you have.

Then see what extensions you installed "eaccelerator,suhosin,sqlite" and search for it by this command:

Code:
locate eaccelerator.so
I know it's a beginner way to do but we are moving step by step to solve this problem but I really think the solution is easy out there but as you know remote solutions are harder than local..
 

pixert

Member
Feb 13, 2011
8
0
51
I find the following

/opt/libmcrypt/lib/libmcrypt.so
/opt/libmcrypt/lib/libmcrypt.so.4
/opt/libmcrypt/lib/libmcrypt.so.4.4.8
/usr/local/cpanel/3rdparty/lib/libmcrypt.so
/usr/local/cpanel/3rdparty/lib/libmcrypt.so.4
/usr/local/cpanel/3rdparty/lib/libmcrypt.so.4.4.8
/usr/local/cpanel/lib/libmcrypt.so.4
/usr/local/cpanel/src/3rdparty/gpl/libmcrypt-2.5.8/lib/.libs/libmcrypt.so
/usr/local/cpanel/src/3rdparty/gpl/libmcrypt-2.5.8/lib/.libs/libmcrypt.so.4
/usr/local/cpanel/src/3rdparty/gpl/libmcrypt-2.5.8/lib/.libs/libmcrypt.so.4.4.8

Which one is the right one?
 

pixert

Member
Feb 13, 2011
8
0
51
# updatedb
# locate *mcrypt.so

I don't know what to do, I never came accross problems like this before?
It's odd. Easy Apache cannot create *.so files in its directory.
 

pixert

Member
Feb 13, 2011
8
0
51
I just disabled error_log in php ini
I'm running the following and get below results
# php -m
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/ex tensions/no-debug-non-zts-20060613/' - /usr/local/lib/php/extensions/no-debug-no n-zts-20060613/: cannot read file data: Is a directory in Unknown on line 0
[PHP Modules]
bcmath
calendar
ctype
curl
date
dom
exif
filter
ftp
gd
gettext
hash
iconv
imap
json
libxml
mbstring
mcrypt
mysql
openssl
pcre
posix
Reflection
session
SimpleXML
sockets
SPL
SQLite
standard
tokenizer
xml
xmlreader
xmlrpc
xmlwriter
zlib

[Zend Modules]
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
I've replied to your PM asking if you had created the folder that is missing (mkdir /usr/local/lib/php/extensions/no-debug-no n-zts-20060613/) and then re-ran EasyApache on the machine.
 

alexcmei

Registered
Jan 25, 2008
2
0
51
[23-Feb-2011 14:48:32] PHP Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20090626/libcurl.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20090626/libcurl.so: cannot open shared object file: No such file or directory in Unknown on line 0


I see the same thing.

'locate' libcurl.so produces locations of libcurl.so - that are non-php extensions.

There's no ext area of easyapache where libcurl.so is built, I've run
find / -name libcurl.so\* on the entire machine and the only places its found are in the system libraries, not the php extension areas.

I've rebuilt easyapache twice now.

While it all looks good from PHP's and Apache's standpoint and phpinfo() returns libcurl as active,
there's no libcurl where you'd think it would be.

however the guardian angel is here..

-rwxr-xr-x 1 root root 547782 Feb 23 14:38 suhosin.so

and is placed properly in - so php can find it.. but not so lucky for libcurl.
/usr/local/lib/php/extensions/no-debug-non-zts-20090626/
 

alexcmei

Registered
Jan 25, 2008
2
0
51
there's no another file in /usr/local/lib/php/extensions/no-debug-non-zts*.
that's odd. php.ini says the correct path, but no .so* file there? easy apache installed the correct modules
I did try easy apache via WHM and SSH, same results
I have the same problem. Did you solve it?
 

rohanluktuke

Registered
Mar 3, 2011
1
0
51
For me, this error was happening because PHP was not able to find and parse the php.ini config file. During PHP installation, the location of php.ini was given as a configuration option. Maybe thats why it never liked any changes to php.ini and always pointed to the "no-debug-.. " extension_dir inspite of giving a different location for extension_dir.

Problem was resolved by setting the PHPRC variable to point to php.ini. It loads the file correctly and takes all changes to php.ini. It loads the libraries located at the extension_dir location.
 

mian66

Member
Feb 14, 2010
6
0
51
Hi

I have the same problem.
I build my apache and php using easyapache in WHM.
After that I get this error when opening website pages:

Code:
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20060613/' - /usr/local/lib/php/extensions/no-debug-non-zts-20060613/: cannot read file data: Is a directory in Unknown on line 0
I'm using php 5.2.16 and after installing zend+ioncube through easyapache this error occured.

Please help me solve this problem.

Thanks