The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Odd error after moving an account

Discussion in 'E-mail Discussions' started by santrix, Mar 29, 2010.

  1. santrix

    santrix Well-Known Member

    Joined:
    Nov 30, 2008
    Messages:
    223
    Likes Received:
    2
    Trophy Points:
    18
    I had to move a couple of accounts the other day from /home2 to /home - long story... anyway, I just went in and dit a partial backup of the homefir and forwarders etc, and then deleted the account, before recreating it on /home and restoring the data (Cpanel won't let you move between directories on the same partition).

    A day later I got a call from the customer saying no email were being received. I noticed for both accounts I moved, that we were getting messages like this in /var/log/exim_mainlog

    Code:
    2010-03-29 12:09:51 H=host81-149-254-226.in-addr.btopenworld.com (blah.blah.co.uk) [81.149.254.xxx] F=<homer@blah.blah.co.uk> temporarily rejected RCPT <wilma@mydomain.co.uk>: require_files: error for /home/mydom1/etc/mydomain.co.uk: Permission denied
    
    In the end I tried creating an extra mailbox in the account.. and sending to it, then it worked fine.. and so did the other mailboxes...

    Can anyone suggest the connection here?
     
  2. jeastman

    jeastman Registered
    PartnerNOC

    Joined:
    Dec 31, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Lansing, MI USA
    I just fixed a similar problem. The issue went back all the way to /home/$user. All the other permissions were correct but somehow /home/$user was set to 750 permissions.
     
Loading...

Share This Page