The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Odd problems with DNS etc.

Discussion in 'Bind / DNS / Nameserver Issues' started by oldlock, Dec 10, 2008.

  1. oldlock

    oldlock Well-Known Member

    Joined:
    Sep 19, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    I have odd, intermittant problems with some of the sites on my VPS with cpanel.

    For background.

    I have three sites, and three IP's. I will not give real names of sites here just examples. All three sites share the same IP. One of the Ip's is assigned for ns1 & the hostname. One is assigned for the sites only and the third for the ns2.

    Firstly there is the hostname which is vps.hostname.com this .com is not used for anything else. The site is running two nameservers ns1.sitea.com and ns2.sitea.com

    The primary site is www.sitea.com this works 100 % no problems.

    The other two sites are www.siteb.com and www.sitec.com and these have constant problems for some users with timeouts etc, but it seems to vary from ISP to ISP.

    Can anyone suggest a course of action to resolve this ? For example should the nameservers be the same as one of the sites - or should they relate to the hostname ?

    Thanks for any advice.
     
  2. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    I can think of multiple issues that can cause this issue.

    First are your nameservers registered properly at your registrar.
    Second do you have A records for your nameservers in your DNS.
    Third are the name servers setup via WHM and the A recrods created there.
    Fourth are the other sites using your nameservers i.e. ns1.sitea.com etc..

    It might help you to do a DNSReport. Since dnsstuff has gotten so expensive you could run a report http://www.checkdns.net/quickcheckdomainf.aspx
     
  3. oldlock

    oldlock Well-Known Member

    Joined:
    Sep 19, 2008
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    6
    Hi randy

    Thanks for the reply, both the test you linked to and intoDNS suggest all is well which is the puzzle. I did also register for the test with DNSstuff and that seems OK too.

    It's very odd ...
     
  4. rhenderson

    rhenderson Well-Known Member

    Joined:
    Apr 21, 2005
    Messages:
    785
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Oklahoma
    cPanel Access Level:
    Root Administrator
    Yes it sounds odd. The only other thing that comes to mind is if Bind is being flakey and taking too long so they are getting time outs. Do you have server spikes that could cause Bind to react slowly? But you would assume all sites would be affected.You might look on your /etc/named.conf and see if everything looks normal, and look in the /var/names/domain.db files. Is your named being moniored by the service manager at WHM >> Main >> Service Configuration >> Service Manager ?

    In another line of thinking, we learned early on is to run backup DNS, we just use a low cost VPS and for a long time just ran cPanel DNS only, we now run a full copy of cPanel for file backups etc... We run our ns1 and ns3 on the main server and ns2 and ns4 on the backup server.
     
Loading...

Share This Page