The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Oddball CSF Quirk That Kills httpd nightly (Chirpy?)

Discussion in 'General Discussion' started by orty, Aug 9, 2007.

  1. orty

    orty Well-Known Member

    Joined:
    Jun 29, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bend, Oregon
    cPanel Access Level:
    Root Administrator
    Hello there!

    I've gone back and forth with the cPanel techs (ticket 196335) on a really oddball little issue. Many nights (generally about 2 out of 3 nights) since the cPanel 11 update, httpd has failed just after upcp ran and I get an email from the chksrvd to that affect. Apace always came back up OK, but I still wanted to figure out what was going on incase it decided to *not* come bac up.

    Nothing in the upcp logs should've been causing Apache to restart.

    Originally, we thought it might have been a resource issue (despite my server having 2gb of RAM and a plenty fast CPU), so we moved the nightly backup process so it was further away (couple hours). that didn't help.

    We made sure Perl was fully up-to-date, and that dependent libraries I was using were up to date. No help.

    We recreated the httpd entry for chksrvd, no help.

    We found and fixed the bug that was occuring in current for a while, no help.

    Load was never up high as my load checking alarms never sent me anything.

    It would stop for a while (a week or so) and then start up again randomly. And chkservd.log would never show that httpd would be attemped to restart.

    So we turned off upcp for a few days, and while httpd didn't fail, chksrvd did fail one of the nights of the 5 or so we left it off. Turned it back on, and then the 2nd night, httpd failed again.

    The cPanel techs were stumped. So last night, after having this ticket open and closed for a couple months now, cPanel had a level 2 tech watch it overnight. After the overnight watch:
    All my ports appear to be open properly:
    tcpin:20,21,22,25,53,80,110,143,443,465,953,993,995,2082,2083,2086,2087,2095,20
    96
    tcpout: 20,21,22,25,37,43,53,80,110,113,443,587,873,953,2087,2089,2703
    udpin: 20,21,53,953
    udpout: 20,21,53,113,123,873,953,6277

    And I went through and whitelisted my server's other IP addresses just to see if that helps.

    To confirm that csf is the problem, without turning the thing off entirely, is there away to have it turned off for just a couple hours during the couple hours when the problem usually occurs? Has anybody else ran into this?

    Thoughts, ideas?
     
  2. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    Re - is there any way to turn csf off? Sure, csf -x does a tolerable job of turning it off and there's another option to turn it back on, simply run those from crontab around the time you want it on and off respectively.
     
    #2 brianoz, Aug 10, 2007
    Last edited: Aug 10, 2007
  3. orty

    orty Well-Known Member

    Joined:
    Jun 29, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bend, Oregon
    cPanel Access Level:
    Root Administrator
    Kewl...I'll give that a whirl and see what happens. Thanks!
     
  4. orty

    orty Well-Known Member

    Joined:
    Jun 29, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bend, Oregon
    cPanel Access Level:
    Root Administrator
    Well I ran csf -x 30 minutes before upcp ran and then csf -e 30 minutes after it was typically over, and httpd still failed last night.

    Back to the drawing board...
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Are you running any of these: SIM, PRM, monit? They can all cause problems on cPanel servers creating race conditions with chkservd.
     
  6. orty

    orty Well-Known Member

    Joined:
    Jun 29, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bend, Oregon
    cPanel Access Level:
    Root Administrator
    Not knowingly, but it may have been installed by Platninum Server Managerment way back in the day. Where do I go look to see?

    On a semi-related note, we turned off the mailscanner update that runs during postupcp, and it hasn't failed for a couple days now. I'll give it a few more days and see if that indeed fixes.

    -Jake
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I can't see how they're related.

    PRM and SIM are in /usr/local/
     
  8. orty

    orty Well-Known Member

    Joined:
    Jun 29, 2004
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bend, Oregon
    cPanel Access Level:
    Root Administrator
    I can't see how they're related, either, but I do know that since cPanel turned it off in the postupcp script, httpd hasn't failed at night (granted, it's only been a few days).

    There was a SIM directory in /usr/local, so I removed that (though it appears it wasn't running in the background according to ps -aux). Nothing for PRM that I could see (looking at PSM's list of stuff they install, they could've very well have installed SIM).

    -j
     
  9. Bailey

    Bailey Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    120
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Wisconsin
    Yep, PSM installs SIM, I can vouch for that one. :)

    :D Bailey
     
Loading...

Share This Page