Office 2007 Files Downloading as ZIP Files in Internet Explorer

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
Hi,

Office 2007 Files Downloading as ZIP Files in Internet Explorer any ideas what to be done to resolve this issue ?
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Can you hover over the actual link before clicking to download it so that we can see what it shows the actual path for the file? If it's wrongly detecting the file type, then that's an issue with that browser more than anything.
 

Infopro

Well-Known Member
May 20, 2003
17,112
513
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
I can duplicate this in IE8. Not clicking a file, opening a URL mydomain.com/filename.xlsx it opens a prompt asking if I want to save filename.zip, I select yes and a prompt opens asking where to save, on that window select where, give the file name shown the correct extension .xlsx and below file name select All Files instead of zip file.
 

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
/http://www.glasscolabs.in/Testing.xlsx open this url in Internet explorer browser & check it will ask to save as .zip extension and if run this in Mozilla or Chrome it downloads as .xlsx need solution

let us know what is the solution ??
 
Last edited:

crazyaboutlinux

Well-Known Member
Nov 3, 2007
939
1
66
yes but question is why we need to do that every time for all websites on the server ??
this is the alternate solutions not primary

the same thing is working on our other sever where i don't need to follow steps mentioned by inforpro
 

Infopro

Well-Known Member
May 20, 2003
17,112
513
613
Pennsylvania
cPanel Access Level
Root Administrator
Twitter
You might find something to go on here.

Like this tip for example:

It is an IE issue and until Microsoft will release a fix in their next IE8 update, this should help:
1. In the upper-right corner of IE8, click on Tools to open the drop down menu;
2. At the bottom of the Tools menu, click Internet Options;
3. In the Internet Options dialog box, select the Security tab;
4. On the Security tab, select the Internet zone, then click the Custom Level button;
5. Scroll about 2/3 down the list to the option "Open file based on content, not file extension" and change the setting to Disable;
6. Click OK;
7. Repeat steps 4-6 for the Local Intranet zone and Trusted Sites zone;
8. Click OK;
9. Close all instances of IE8;
10. Reopen IE8 and it should now recognize Office 2007 and 2010 file extensions when saving email attachments.
Now if that tip does indeed work for you, we can safely assume this is not an issue with cPanel I would think. :)

GL!